Bug 74514 - FORMATTING; DATA SERIES; explicit data series not imported from excel.
Summary: FORMATTING; DATA SERIES; explicit data series not imported from excel.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart-Data
  Show dependency treegraph
 
Reported: 2014-02-04 16:41 UTC by Bob Harvey
Modified: 2019-03-23 20:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original excel spreadsheet with explicit data ranges (15.00 KB, application/vnd.ms-excel)
2014-02-04 16:41 UTC, Bob Harvey
Details
Screen grab of the excel file and chart (172.42 KB, image/jpeg)
2014-02-04 16:42 UTC, Bob Harvey
Details
Screen grab of the excel data range dialogue showing how the horizontal line was produced (57.50 KB, image/jpeg)
2014-02-04 16:43 UTC, Bob Harvey
Details
Screen grab of the excel data range dialogue showing how the vertical line was produced (46.00 KB, image/jpeg)
2014-02-04 16:43 UTC, Bob Harvey
Details
Screen grab of the .xls file opened in calc. Not the same. (172.42 KB, image/jpeg)
2014-02-04 16:45 UTC, Bob Harvey
Details
Screen grab of the excel data range dialogue showing how the horizontal line was produced - correct file uploaded! (46.33 KB, image/jpeg)
2014-02-04 16:46 UTC, Bob Harvey
Details
Screen grab of the horizontal data line range as displayed in calc (57.50 KB, image/jpeg)
2014-02-04 16:46 UTC, Bob Harvey
Details
Screen grab of the vertical data line range as displayed in calc (57.09 KB, image/jpeg)
2014-02-04 16:47 UTC, Bob Harvey
Details
Data file after being opened in calc and saved as default format (17.49 KB, image/jpeg)
2014-02-04 16:48 UTC, Bob Harvey
Details
Data file after being opened in calc and saved in .xls format (8.50 KB, application/vnd.ms-excel)
2014-02-04 16:49 UTC, Bob Harvey
Details
Screen grab once opened in calc and re-saved as .xls, then re-opened in excel (236.08 KB, image/jpeg)
2014-02-04 16:52 UTC, Bob Harvey
Details
Screen grab once opened in calc and re-saved as .xls then re-opened in excel - the explicit data ranges have gone (44.30 KB, image/jpeg)
2014-02-04 16:53 UTC, Bob Harvey
Details
PDF saved from Excel 2010 (7.17 KB, application/pdf)
2014-10-29 16:09 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Harvey 2014-02-04 16:41:17 UTC
Created attachment 93373 [details]
Original excel spreadsheet with explicit data ranges

One of the features I use a lot in Excel is to create a data series explicitly from a {value list} instead of off the cells in the spreadsheet.  I use it to draw lines on the chart for engineering limits, but there will be other reasons for doing it.

Calc does not support these explicit data series at all.
Comment 1 Bob Harvey 2014-02-04 16:42:29 UTC
Created attachment 93374 [details]
Screen grab of the excel file and chart
Comment 2 Bob Harvey 2014-02-04 16:43:18 UTC
Created attachment 93375 [details]
Screen grab of the excel data range dialogue showing how the horizontal line was produced
Comment 3 Bob Harvey 2014-02-04 16:43:59 UTC
Created attachment 93376 [details]
Screen grab of the excel data range dialogue showing how the vertical line was produced
Comment 4 Bob Harvey 2014-02-04 16:45:08 UTC
Created attachment 93377 [details]
Screen grab of the .xls file opened in calc.  Not the same.
Comment 5 Bob Harvey 2014-02-04 16:46:05 UTC
Created attachment 93378 [details]
Screen grab of the excel data range dialogue showing how the horizontal line was produced - correct file uploaded!
Comment 6 Bob Harvey 2014-02-04 16:46:49 UTC
Created attachment 93379 [details]
Screen grab of the horizontal data line range as displayed in calc
Comment 7 Bob Harvey 2014-02-04 16:47:27 UTC
Created attachment 93380 [details]
Screen grab of the vertical data line range as displayed in calc
Comment 8 Bob Harvey 2014-02-04 16:48:08 UTC
Created attachment 93381 [details]
Data file after being opened in calc and saved as default format
Comment 9 Bob Harvey 2014-02-04 16:49:23 UTC
Created attachment 93382 [details]
Data file after being opened in calc and saved in .xls format
Comment 10 Bob Harvey 2014-02-04 16:52:00 UTC
Created attachment 93383 [details]
Screen grab once opened in calc and re-saved as .xls, then re-opened in excel
Comment 11 Bob Harvey 2014-02-04 16:53:50 UTC
Created attachment 93384 [details]
Screen grab once opened in calc and re-saved as .xls then re-opened in excel - the explicit data ranges have gone
Comment 12 Bob Harvey 2014-02-04 16:55:45 UTC
This is a compatability issue with excel.  As the attachments show, opening a known good .xls produces a different graph in calc, and if re-saved as an .xls from calc the explict data ranges are gone when reverting to excel.

It is also something of a shame that the rather convenient feature that allows me to draw on a graph without creating dummy data series is not available in calc.
Comment 13 Buovjaga 2014-10-29 16:09:01 UTC
Created attachment 108633 [details]
PDF saved from Excel 2010

PDF showing, how it should look like.
Comment 14 Buovjaga 2014-10-29 16:11:34 UTC
I confirm that Calc still doesn't show it like it's supposed to.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 4586a3f564600f1a0ce15a5cb98868b43bb9351e
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-29_07:28:16
Comment 15 Buovjaga 2015-01-07 15:56:49 UTC
Lowered version number after reproducing with:

Ubuntu 14.10 64-bit
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 16 QA Administrators 2016-01-17 20:03:14 UTC Comment hidden (obsolete)
Comment 17 Bob Harvey 2016-01-18 08:36:39 UTC
I can confirm that this bug is still present in 5.0.4.2
Comment 18 Bob Harvey 2016-01-18 16:52:56 UTC
I can confirm as requested that this bug was carried over from OOo (and is still present in OOo 4.1.2)
Comment 19 QA Administrators 2017-03-06 14:06:30 UTC Comment hidden (obsolete)
Comment 20 Bob Harvey 2017-03-06 15:01:56 UTC
I can confirm that this behaviour is unchanged in 5.3, and is unchanged
Comment 21 QA Administrators 2018-03-07 03:40:56 UTC Comment hidden (obsolete)
Comment 22 Bob Harvey 2018-03-21 12:47:32 UTC
Tested in 6.0.2.1 and still present

Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-GB (en_GB); Calc: group
Comment 23 QA Administrators 2019-03-22 04:04:29 UTC Comment hidden (obsolete)
Comment 24 Bob Harvey 2019-03-22 11:35:19 UTC
Bug still present in 6.2.1.2 installed yesterday
Comment 25 QA Administrators 2019-03-23 03:17:48 UTC Comment hidden (obsolete)
Comment 26 Bob Harvey 2019-03-23 18:25:28 UTC
I think your robot has gone wrong.
I just answered this when it appeared as comment 23, and it is back as comment 25 a day later.
No, it has NOT been fixed yet.
Comment 27 Buovjaga 2019-03-23 20:48:20 UTC
(In reply to Bob Harvey from comment #26)
> I think your robot has gone wrong.
> I just answered this when it appeared as comment 23, and it is back as
> comment 25 a day later.
> No, it has NOT been fixed yet.

I have reported the misbehaving robot to the authorities.