Bug 74614 - Other: Sorting hangs with certain table, even when imported from CSV
Summary: Other: Sorting hangs with certain table, even when imported from CSV
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression, regression
Depends on: 72470
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-06 13:24 UTC by Kai Becker
Modified: 2015-12-15 10:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The sample table (762.43 KB, text/csv)
2014-02-06 13:24 UTC, Kai Becker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Becker 2014-02-06 13:24:28 UTC
Created attachment 93525 [details]
The sample table

Problem description: 

Sorting a specific table (6000rows x <10cols) hangs in V4.2.0.
Sorting the same table worked in previous version.

Steps to reproduce:

1. Import the CSV attached
2. Fix top row as column descriptions
3. Sort by any column

Current behavior:

Sorting hangs, showing the Mac beach ball forever.

Expected behavior:

Sorting the table :)
              
Operating System: Mac OS X
Version: 4.2.0.4 release
Last worked in: 4.1.5.1 rc
Comment 1 m.a.riosv 2014-02-07 00:23:51 UTC
Hi Kai, thanks for reporting.

No reproducible with:
Win7x64Ultimate
Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Comment 2 Kai Becker 2014-02-07 09:57:13 UTC
Deleted the user profile and tried again: same result.

Note: I'm using Mac OS X 10.9.

Then CHANGED the CHARSET in the CSV-import form "Unicode (UTF-8)" to "Westeuropa (ISO-8859-1)" ==> Sorting works.

Then tested the same with V4.2.0.4 on WINDOWS XP(en):
+ When imported with charset "Unicode (UTF-8)" ==> Sorting hangs
+ When imported with charset "Westeuropa (ISO-8859-1)" ==> Sorting works

So, there seems to be a problem with certain cell content when importing UTF-8.

Hint: UTF-8 is default on Mac, while ISO-8859-1 is default on Windows.
Comment 3 m.a.riosv 2014-02-07 11:05:15 UTC
Importing as UTF-8 the issue is also in Windows, so seems a bug is there.

I have found the problem start with cell J2188, and you don't need to sort, try deleting the cell and LibreOffice hangs, below is the row in the CSV file:

"F130RB01FG","F130RB01FG","BOOL",100217,,6,"5.0",3,"El.Verrieg., Freigabe RB01 von F130 an F120","Meldeleuchten_BK50, Meldeleuchten_BK51, Rangierung"

There are strange characters at the begin of the second reference, and seems that lines with them have the problem.

Regression from:
Win7x64
Version: 4.1.6.0.0+ Build ID: fd07d1758ee62eebfe95b157ba651de282feec0
Comment 4 Kohei Yoshida 2014-02-08 14:51:58 UTC
This may be another manifestation of Bug 72470.  Please re-check with the build that has the fix for Bug 72470.
Comment 5 m.a.riosv 2014-02-08 16:45:37 UTC
Retested, works for me with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 63950ec72806489b41c2109f5c3840dcf22f4c6c
        TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_00:47:07

Bug is still reproducible with 4.2.0.4.

Changed status: duplicate 72470, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 72470 ***
Comment 6 Robinson Tryon (qubit) 2015-12-15 10:53:37 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]