Download it now!
Bug 74656 - Macros: VBA macro which defines function doesn't work on save as ods and reopening of the file: #NAME?
Summary: Macros: VBA macro which defines function doesn't work on save as ods and reop...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-07 09:05 UTC by eng.GeorgiGeorgiev
Modified: 2015-08-02 10:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Both XLS and ODS files. Yellow field to be changed (16.60 KB, application/zip)
2014-02-07 09:05 UTC, eng.GeorgiGeorgiev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eng.GeorgiGeorgiev 2014-02-07 09:05:01 UTC
Created attachment 93592 [details]
Both XLS and ODS files. Yellow field to be changed

Problem description: 
When I open an Excel file with very simple VBA macro in it, in Calc everything works fine. When I save the file in ODS format it also works fine. But when I reopen the ODS file with Calc the macro is not working (the macro defines new function called Linearinterp). I know that similar bug was reported, but it was for macros that doesn't work back in Excel, here problem is in the ods file, looking in the macro code the Calc is converting it someway, but still doesn't work    
Steps to reproduce:
1. Open xls file
2. Save as...*.ods
3. Reopen the *.ods file

Current behavior:
Formula that is defined with the macro is not working on reopening
Expected behavior:
To have macro works fine.

              

              
Operating System: Windows XP
Version: 4.1.4.2 release
Comment 1 Cor Nouws 2014-05-01 23:06:40 UTC
Hi Georgi,

I confirm the behaviour > set to New.
Did you happen to see if it worked correct in earlier versions?
thanks,
Cor
Comment 2 Cor Nouws 2014-05-01 23:06:56 UTC
(by the way: I tested in 4.2.4.1)
Comment 3 eng.GeorgiGeorgiev 2014-05-05 06:35:02 UTC
(In reply to comment #1)
> Hi Georgi,
> 
> I confirm the behaviour > set to New.
> Did you happen to see if it worked correct in earlier versions?
> thanks,
> Cor

Hello Cor,
actually this is the only version I've tested it (4.1.4.2). I don't know if it works on earlier versions,
Regards,
Georgi
Comment 4 Cor Nouws 2014-05-06 18:30:21 UTC
I see the same behaviour in LibreOffice 3.3.0, so I guess this is not yet implemented in the VBA-interoperability (See also Tools > Options > Load/Save > VBA Properties)
Comment 5 QA Administrators 2015-06-08 14:42:47 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 6 Buovjaga 2015-08-02 10:39:53 UTC
Tested by saving xls as ods and reloading. It works now.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-30_03:52:07
Locale: en-US (fi_FI)