In Calc, in Tools > Customize... > Keyboard tab > Category list > Edit, in the Function list, there is an entry "Paste Only Value".
About "Paste Only Value," it has been said :
> Paste Only Value equates to selecting Numbers in the Paste Special... dialog,
> which is not very clear to me either. I think a value can be either a string or
> a number.
This was illustrated in , in which the column "Value/Number," rows "UNO function," shows the results of this "Paste Only Value" keybinding. Numbers are pasted, but strings and dates are not.
Can rewording "Paste Only Value" to "Paste Only Numbers", for consistency, be considered?
asking for ux input here, if it's agreed to do this change I'll do it
UX: For you!
Component -> ux-advise
Status -> NEW
Another argument for renaming is that the paste special dialog talks about numbers and not values. So yes, please rename.
EASYHACK, NEEDINFO for the additional infos.
Missing keywords: difficulty<foo>, topicUI
Please add these, or remove easyHack keyword.
Changing status: NEEDINFO -> NEW
Adding keyword 'needsDevEval'
hi, i'm Mirco, I work in this bug, it is the first easyhack.
(In reply to Mirco Rondini from comment #6)
> hi, i'm Mirco, I work in this bug, it is the first easy hack.
Welcome hope you will have fun, please have a look at:
to help you get started.
I have make the change, but I need to change the name of function ".uno:PasteOnlyValue" into ".uno:PasteOnlyNumbers" too?
<node oor:name=".uno:PasteOnlyValue" oor:op="replace">
<prop oor:name="Label" oor:type="xs:string">
<value xml:lang="en-US">Paste Only Numbers</value>
searching ".uno:PasteOnlyValue" into opengrok I have find only other 2 references:
18 <menu:menuitem menu:id=".uno:PasteOnlyValue"/>
87 <menu:menuitem menu:id=".uno:PasteOnlyValue"/>
(In reply to Mirco Rondini from comment #8)
> I have make the change, but I need to change the name of function
> ".uno:PasteOnlyValue" into ".uno:PasteOnlyNumbers" too?
> <node oor:name=".uno:PasteOnlyValue" oor:op="replace">
> <prop oor:name="Label" oor:type="xs:string">
> <value xml:lang="en-US">Paste Only Numbers</value>
> searching ".uno:PasteOnlyValue" into opengrok I have find only other 2
> 1) /core/sc/uiconfig/scalc/popupmenu/cell.xml
> 18 <menu:menuitem menu:id=".uno:PasteOnlyValue"/>
> 2) /core/sc/uiconfig/scalc/menubar/menubar.xml
> 87 <menu:menuitem menu:id=".uno:PasteOnlyValue"/>
I would not change the uno API, that is something we do not do easily as it might affect a lot of programs.
Mirco Rondini committed a patch related to this issue.
It has been pushed to "master":
tdf#74740 <change "Paste Only Value" to "Paste Only Numbers">
It will be available in 5.3.0.
The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
Affected users are encouraged to test the fix and report feedback.