Bug 74810 - Other: SORTING hangs for at least one spreadsheet
Summary: Other: SORTING hangs for at least one spreadsheet
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-10 20:41 UTC by Ralph Martin
Modified: 2014-02-11 02:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Data which shows the aberrant behaviour. (148.86 KB, text/csv)
2014-02-10 20:41 UTC, Ralph Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Martin 2014-02-10 20:41:45 UTC
Created attachment 93804 [details]
Data which shows the aberrant behaviour.

Problem description: 
Attempting to sort the attached spreadsheet hangs, and never returns.

Steps to reproduce:
1. Open the attached spreadsheet (as utf-8, comma separated)
2. Select all data by clicking in top left of sheet
3. Choose Data -> Sort
4. Under Options, choose Range Contains Column Labels (this step may not actually needed)
4. Choose any set of columns to sort by
5. Click OK

Current behavior:
The app never returns, just displaying a spinning wait cursor

Expected behavior:
Data should get sorted.
Previous versions of OpenOffice definitely sorted this file OK, although it has been edited slightly since; I'm not sure which was the last version to work.
              
Operating System: Mac OS X
Version: 4.2.0.4 release
Comment 1 m.a.riosv 2014-02-10 21:29:06 UTC
Hi Ralph, thanks for reporting.

I think it is the same issue as in:
https://bugs.freedesktop.org/show_bug.cgi?id=74614

what is a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=72470

Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 72470 ***
Comment 2 Michael 2014-02-10 22:39:57 UTC
Hello,

This seems not to be an issue of text input as in bug 72470 but rather of CSV import, I'd suggest to reopen the issue.
Comment 3 Ralph Martin 2014-02-10 23:07:55 UTC
Well, the spreadsheet does have some Chinese text in it.
Comment 4 m.a.riosv 2014-02-11 00:46:17 UTC
Please try with 4.2.1, to see it is fixed.
http://dev-builds.libreoffice.org/daily/libreoffice-4-2/
Comment 5 Kevin Suo 2014-02-11 01:45:05 UTC
(In reply to comment #2)
> Hello,
> 
> This seems not to be an issue of text input as in bug 72470 but rather of
> CSV import, I'd suggest to reopen the issue.

The spreadsheet does have CJK chars in column E, and because of the issue discussed in Bug 72470 it crashes when you sort, copy or editing etc.
Comment 6 m.a.riosv 2014-02-11 02:57:31 UTC
Reproducible with 4.2.0.4.

Verified fixed.
Win7x64Ult.
Version: 4.2.1.0.0+ Build ID: 684a0308dcb847f816967202ba87f536b83dcb4e
        TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-10_23:09:14

So seems it really was a duplicate of 72470.

Changed the status, please if you still can reproduce it with 4.2.1.0, reopen it.
http://dev-builds.libreoffice.org/daily/libreoffice-4-2/

*** This bug has been marked as a duplicate of bug 72470 ***