Bug 74893 - Other: array ctrl+shift+enter only seems to work on new functions not existing
Summary: Other: array ctrl+shift+enter only seems to work on new functions not existing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-12 15:54 UTC by afonit
Modified: 2015-05-20 06:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the example workbook referred to in the long description of this bug (13.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-12 15:54 UTC, afonit
Details
ods file with 2 arrays : 1 you can modify and 1 other you can't (40.78 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-16 09:21 UTC, Thierry Munoz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description afonit 2014-02-12 15:54:55 UTC
Created attachment 93940 [details]
the example workbook referred to in the long description of this bug

Problem description: 
if I have an existing function and I hit f2 to edit then ctrl+shift+enter to turn it into an array function, it does not work.  However, If I enter in the function for the first time in a new cell (and while I am still in that cell from typing the function) then ctrl+shift+enter turns the function into an array.

Steps to reproduce:
1. open the attached spreadsheet
2. hit f2 on C7 then hit ctrl+shift+enter
3. notice the function does not turn into an array
4. now in cell C8 hit f2 and paste in =SUM(A1:A4*B1:B4) then hit ctrl+shift+enter
5. you will now see C8 is an array function



Current behavior:
ctrl+shift+enter only works on just entered formulas

Expected behavior:
ctrl+shift_enter should work on a formula that is already entered and you are now turning it into an array.


Note:
I know the example in the attached workbook could be resolved using sumproduct(), however the real example I have is a bit more complex, so I chose a simpler example that could still illustrate the point/issue.

docs:
https://help.libreoffice.org/Calc/Array_Functions

              
Operating System: Linux (Other)
Version: 4.2.0.4 release
Comment 1 sophie 2014-02-12 16:50:04 UTC
Hi, I can confirm that an existing formula can not be change into an array if you edit it with F2 and then press ctrl+shift+enter. I've also tried 4.1.5.3 and this is the same. I'll put the issue on New.

As a workaround I've found that if you select the formula once you've press F2, you are able the change it in an array once ctrl+shif+enter is pressed. However not being able to do it straightly if the formula is edited seems wrong to me. 

Change version to 4.1.5 as this is the first version where I've been able to reproduce. Set to New - Sophie
Comment 2 GerardF 2014-02-12 18:12:55 UTC
LibreOffice and previously OpenOffice have always works like this. (unlike Excel)
Change version to Inherited from OOo.
Comment 3 Thierry Munoz 2014-02-16 09:21:40 UTC
Created attachment 94154 [details]
ods file with 2 arrays : 1 you can modify and 1 other you can't

Hi,
I confirm this behavior on LibO 4.2.0.4 under Ubuntu 12.04.
But not with all the functions :
- Impossible to edit an array with IF function
- No problem to editing an array with FREQUENCY function.

See the attachment and in the sheet "Feuille2" :
- array editable in C2:C5 with FREQUENCY function
- array not editable in A11:A40 with IF function.
Comment 4 Joel Madero 2015-05-02 15:41:31 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 5 Winfried Donkers (retired) 2015-05-20 06:10:45 UTC
Checked with version 4.4.3.2:

Created a new function and pressed ctrl-shift-enter to make it an array function.
That worked fine.

Hit F2 to modify the function; modified the function and pressed ctrl-shift-enter.
That worked fine too.
(tested both with the caret in the middle and with the caret at the end of the formula, both worked fine.)