Bug 75008 - EDITING: Typography Toolbar and Graphite Features missing
Summary: EDITING: Typography Toolbar and Graphite Features missing
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-02-14 23:48 UTC by josh.d.nichols
Modified: 2015-12-15 10:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description josh.d.nichols 2014-02-14 23:48:16 UTC
Problem description: 

Graphite features, either manually set via extensions or automatically set by the Typography Toolbar, does not show typographical adjustments nor export them to PDF.

Steps to reproduce:
1. Open Writer (in Windows 7)
2. type some text
3. highlight said text
4. Either manually enter a graphite extension in the font box or choose one of the typographical buttons on the typography toolbar. For true small caps, add ":smcp=1" to the font box or select "Small Caps" fromt the typography toolbar.

Current behavior:

No change in the typography on the screen or in an export to PDF. However, when sending directly to printer, the changes are reflected in the print.

Expected behavior:

One should be able to see the updated changes in typography on the screen and in the PDF.
              
Operating System: Windows 7
Version: 4.2.0.4 release
Last worked in: 4.1.4.2 release
Comment 1 Joel Madero 2014-06-21 03:16:36 UTC
LibreOffice is not responsible for third party extensions. We host the extensions but the developers are responsible for keeping them up to date - and we have no way of reaching out to the developer. 

FWIW I tested on 4.1.4.2 release on Ubuntu 14.04 x64 and saw the same behavior - did not see a change when I clicked on "Small Caps" button from toolbar. 

Closing as NOTOURBUG
Comment 2 Joel Madero 2014-06-21 03:19:57 UTC
I actually think this is a good enhancement request if you want to report a new "bug" that requests that we incorporate this toolbar into core code :)
Comment 3 josh.d.nichols 2014-06-26 18:07:23 UTC
I don't know how to do that!

IC,

Josh


On Fri, Jun 20, 2014 at 10:19 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 2 <https://bugs.freedesktop.org/show_bug.cgi?id=75008#c2> on
> bug 75008 <https://bugs.freedesktop.org/show_bug.cgi?id=75008> from Joel
> Madero <jmadero.dev@gmail.com> *
>
> I actually think this is a good enhancement request if you want to report a new
> "bug" that requests that we incorporate this toolbar into core code :)
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 4 Joel Madero 2014-06-27 06:54:30 UTC
Just report a new bug and cc me on it :) Or email me and give me the bug id and I'll do the appropriate steps on it :) Thanks!
Comment 5 László Németh 2014-06-27 08:27:58 UTC
Typography toolbar works only with Linux Libertine G and Linux Biolinum G fonts shipped with the packages of LibreOffice.org, or you can download them here: http://numbertext.org/linux/. Thanks for your bug report!
Comment 6 Robinson Tryon (qubit) 2015-12-15 10:55:17 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]