Download it now!
Bug 75217 - Dialogues can't be handled nor evaluated any more
Summary: Dialogues can't be handled nor evaluated any more
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-19 16:24 UTC by Fritz R. Paul
Modified: 2015-02-20 13:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The attached document contains a dialogue and macros to handle it to demonstrate the issue. (27.22 KB, application/vnd.oasis.opendocument.text)
2014-02-19 16:24 UTC, Fritz R. Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fritz R. Paul 2014-02-19 16:24:08 UTC
Created attachment 94369 [details]
The attached document contains a dialogue and macros to handle it to demonstrate the issue.

LO 4.2 seems to use an own context for dialogue callbacks with BASIC macros. Dialogues can't be handled nor evaluated any more! It is still working properly in 4.1.5.

This is a blocking issue for the usage of the 4.2 version for all environments that rely on automated writer templates using dialogues.
Comment 2 Thomas Arnhold 2014-05-13 05:53:18 UTC
Sorry, wrong bug. I can confirm your problem.
Comment 3 Niklas Johansson 2015-02-20 13:32:03 UTC
I can not reproduce this problem with either of LibreOffice 4.2.8 or LibreOffice 4.4.0 using Windows. So I will close this as resolved works for me.

Just in case I misunderstood something and the problem still exist, please feel free to reopen.