Bug 75409 - UI: Mouse scroll wheel operates inconsistently in slide panel
Summary: UI: Mouse scroll wheel operates inconsistently in slide panel
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-23 18:59 UTC by Callegar
Modified: 2015-06-08 15:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample slide show which has shown problem (213.71 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-10-14 01:33 UTC, Edward Z. Yang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2014-02-23 18:59:29 UTC
Problem description:

When you have a presentation with many slides and the slides panel on the left, the mouse scroll wheel behaves inconsistently on it. Scrolling down with wheel selects the next slide (as expected), Scrolling up with wheel jumps to the first slide, instead of the previous slide.
Operating System: Ubuntu
Version: 4.2.0.4 release
Comment 1 Jean-Baptiste Faure 2014-04-21 20:29:25 UTC
I do not reproduce with LibreOffice 4.2.5.0.0+ under Ubuntu 14.04 x86-64. The mouse select the slide which is under the pointer, whatever the direction of the scroll with the wheel is.

What happens if you scroll with the mouse wheel, maintaining the pointer in the middle of the slides panel?

Best regards. JBF
Comment 2 Edward Z. Yang 2014-10-14 01:33:58 UTC
Created attachment 107798 [details]
sample slide show which has shown problem

I can also reproduce this behavior, stock LibreOffice Version: 4.2.6.3
Build ID: 420m0 (Build:3) on Ubuntu 14.04.

However, reproducing the bug is REALLY touchy. If I resize the window, or the slide pane, or even just scroll around a bit, I can often cause LibreOffice to revert back to its old behavior. Closing and reopening the slide window sometimes helps the bug manifest, but not reliably. Dragging the slide pane back to its old dimensions sometimes helps, but also not reliably. I find the bug happens more reliably with smaller pane sizes. I once got the slide pane to get "stuck" if you were at the very top, but scrollable elsewhere.

Once, by fullscreening LibreOffice I induced the original bug, then resizing the slide pane gave me the "stuck at top bug", and resizing it one more time put me back in the correct state.

I wish I could give you a recipe to reproduce, but I really don't know what factors are influencing it. Try a different monitor. Try just scrolling around a while and seeing if something bad happens. I do know it happens often enough to be annoying!
Comment 3 Buovjaga 2014-11-27 11:21:34 UTC
I don't understand this talk about scrolling selecting slides: I get no such behavior, it simply scrolls the list.
Or are you talking about slide show? I don't know how to display the list with the slide show.

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 6b219f012edbe069c461f4e0746898e33fa1dd49
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-25_21:56:46
Comment 4 Callegar 2014-11-27 12:15:40 UTC
Difficulty in reproducing is understandable. It already was an intermittently occurring phenomenon. At this point it is not even clear if 4.3.x still carries the bug or if the bug was triggered by some specific machine configuration.
Hope was that, by creating an issue, someone was able to provide a reliable means of triggering the issue.
Comment 5 Edward Z. Yang 2014-12-09 02:37:59 UTC
"scrolling selecting slides"

To be clear, I am only referring to scrolling the pane, not actually changing what slide is being viewed in the main pane.
Comment 6 QA Administrators 2015-06-08 14:28:57 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 7 Callegar 2015-06-08 15:47:20 UTC
I have not reproduced the bug in recent versions of LibO.
Comment 8 Buovjaga 2015-06-08 15:56:11 UTC
All right, thanks for replying! I'll set this to WFM, then.