Download it now!
Bug 75414 - Edits COMPLETELY LOST on file save!!!
Summary: Edits COMPLETELY LOST on file save!!!
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: x86 (IA32) All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-23 21:59 UTC by Dave Nadler
Modified: 2015-06-20 14:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
example ODP for reproducing bug (1.53 MB, application/vnd.oasis.opendocument.presentation)
2014-02-23 21:59 UTC, Dave Nadler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Nadler 2014-02-23 21:59:31 UTC
Created attachment 94622 [details]
example ODP for reproducing bug

Using example provided, go to slide 14.
Edit the bullet starting with 9,000 (ie, add some text).
Save the file, close, reopen.

The edits have been completely lost!!!
HELP!!!
Comment 1 sophie 2014-02-24 14:45:11 UTC
Hi, 
I can not reproduce with Version: 4.2.1.1
Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b on Ubuntu 13.10. Please could you try with the 4.2.1.1 version and see if it's always the same?
Lowering the importance until Dave's feedback, it's not a MAB. Thanks - Sophie
Comment 2 Dave Nadler 2014-02-24 17:21:17 UTC
Please, I would like to help and have already spent a bunch of time narrowing down an easily reproducible example. But I have already lost a bunch of time with lost edits, and I can't load an experimental version just before I must make this presentation! Please, can you try to reproduce with the release version I am using? Thanks!
Comment 3 sophie 2014-02-24 17:32:23 UTC
Dave, if the bug is corrected with version 4.2.1.1, then it's not needed to reproduce it with 4.2.0. Because I don't use the same operating system as yours, I can't say if it appears on Windows or not with this new version. So, we will wait for another QA member to test under Windows. Thanks for your report! Sophie
Comment 4 Julien Nabet 2014-02-24 20:08:21 UTC
I can reproduce this on:
- Windows7, with LO 4.1.5, 
- pc Debian x86-64 with master sources updated yesterday and 4.2 sources updated yesterday too.

I noticed nothing special on console.
Comment 5 Julien Nabet 2014-02-24 20:09:55 UTC
Just for the record, I went to slide 14, first bullet (the one which begins with 9,000) and replaced this:
9,000+ ft plus climb
by this:
9,000+ ft test plus climb

No error message during saving but when reopen , "test" doesn't appear.
Comment 6 Julien Nabet 2014-02-24 20:30:01 UTC
Dave: I made some other tests and found that when using fodt, editing/saving/reopen was ok.
Of course, it would be just a workaround.
Comment 7 Dave Nadler 2014-02-24 21:19:09 UTC
I'm glad you folks can reproduce the problem.
I lost a LOT of work yesterday with this bug
(plus other crashing I don't know how to reproduce).

PLEASE consider this a very serous bug!
Thanks,
Best Regards, Dave
Comment 8 Julien Nabet 2014-02-24 21:24:36 UTC
Dave: I wonder if there could be something corrupted in your file.
Do you reproduce this with a brand new file without copying from your original file? (Just try with 1 slide and a quick bulleted list)
Comment 9 Julien Nabet 2014-02-24 21:33:34 UTC
http://odfvalidator.cyclone3.org/ indicates some errors but I don't know if they could be false positives.
There's also http://odf-validator.rhcloud.com/ but the service is unavailable for the moment.

Joren: would you have some time (it's very quick and straightforward) to give a try to this bug? The weird thing is Sophie doesn't reproduce this whereas I can reproduce this.
Comment 10 Dave Nadler 2014-02-25 12:36:45 UTC
(In reply to comment #8)
> Dave: I wonder if there could be something corrupted in your file.
> Do you reproduce this with a brand new file without copying from your
> original file? (Just try with 1 slide and a quick bulleted list)

I am SURE there is something corrupted in the file.
Like every other user out there, I'm creating presentations
using a mix of older presentation decks. IIRC this presentation
was created originally with an earlier version of Libre Office
(maybe Open Office prior the fork), but it may have been PowerPoint.

Hope that helps,
Best Regards, Dave
Comment 11 Joel Madero 2015-05-02 15:42:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 12 Buovjaga 2015-06-20 14:49:16 UTC
(In reply to Julien Nabet from comment #5)
> Just for the record, I went to slide 14, first bullet (the one which begins
> with 9,000) and replaced this:
> 9,000+ ft plus climb
> by this:
> 9,000+ ft test plus climb
> 
> No error message during saving but when reopen , "test" doesn't appear.

Test text is retained for me. Closing as WFM.

Ubuntu 15.04 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-06-20_00:06:19
Locale: en-US (en_US.UTF-8)

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)