Bug 75516 - UI: Resizing chart freezes libreoffice and grabs the mouse
Summary: UI: Resizing chart freezes libreoffice and grabs the mouse
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-26 01:06 UTC by Alexandre
Modified: 2017-07-12 15:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test spreadsheet (472.29 KB, application/x-7z-compressed)
2014-02-26 01:06 UTC, Alexandre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre 2014-02-26 01:06:43 UTC
Created attachment 94744 [details]
Test spreadsheet

Problem description: 

Steps to reproduce:
1. .... Open the attached spreadsheet
2. .... attempt to resize (enlarge) the chart
3. .... ;)

Current behavior: The program enters an (infinite?) loop and freezes. Nothing responds. The mouse is grabbed (window manager interaction?) and useless while it is's freeze (even xkill is unable to grab the mouse). 

Expected behavior: Resize the chart and not take forever while doing it ;)

              
Operating System: Debian
Version: 4.2.0.4 release
Comment 1 Thomas van der Meulen 2014-02-26 12:42:27 UTC
Thank you for your bug report, 
I can reproduce that LibreOffice freezes wen I wanted to resize the chart, also the file hang on opening and scrolling.
Comment 2 retired 2014-02-27 12:27:42 UTC
NEw as of comment 1.
Comment 3 Joel Madero 2015-05-02 15:42:32 UTC Comment hidden (obsolete)
Comment 4 Alexandre 2015-05-02 19:47:57 UTC
The bug is still present as of  4.4.2.2. No changes in behavior. Debian amd64.
Comment 5 QA Administrators 2016-09-20 09:38:19 UTC Comment hidden (obsolete)
Comment 6 Alexandre 2017-06-30 14:07:14 UTC
Can't reproduce the problem anymore - tested with v5.3.1