Bug Hunting Session
Bug 75553 - Font embedding corrupts asian font and includes in western document
Summary: Font embedding corrupts asian font and includes in western document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-27 01:26 UTC by Pedro
Modified: 2015-04-14 14:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2014-02-27 01:26:02 UTC
Embedding fonts in ODP and ODT using LO 4.1.4.2 and 4.2.1.1 under Windows XP results in a larger than expected file.

In addition to the font used on the document, some other unrelated fonts are packaged, including a large 10.512.252 bytes "font" which is probably a corrupted version of simsun.ttc (10.512.288 bytes) also not used in the document...
Comment 1 Pedro 2014-02-27 01:38:03 UTC
Unfortunately I can't attach the file because due to the bug the size is larger than expected by Bugzilla :)

Here is the link
https://dl.dropboxusercontent.com/u/2347109/Font_embedding_in_ODF_1.2_LO414.odt
Comment 2 Maxim Monastirsky 2014-02-27 09:36:16 UTC

*** This bug has been marked as a duplicate of bug 65353 ***
Comment 3 Pedro 2014-02-27 09:52:55 UTC
I have modified the summary. In addition to the fonts added in excess (which is explained in Bug #65353 but could be corrected) there is a more serious problem reported in this bug: the large asian font simsun.ttc is corrupted before it is embedded
Comment 4 tommy27 2014-10-17 11:39:23 UTC
pinging old unconfirmed bugs.

is the issue still reproducible with LibO 4.3.2.2?
thanks for your feedback
Comment 5 Pedro 2014-10-17 12:01:17 UTC
Hi Tommy

> is the issue still reproducible with LibO 4.3.2.2?

Yes, i can confirm the bug is still there. Not only it embeds more fonts than expected but also embeds a large corrupted font (not used in the document).
Comment 6 Joel Madero 2014-11-20 06:23:43 UTC
@Lubos - ideas on this one? When I extract the document I see the SimSun font throughout but I don't actually see it used at all in the document. The font is corrupted and huge
Comment 7 Pedro 2015-04-14 14:24:12 UTC
The problem with the corrupted Asian font seems to be fixed (closing this as WORKSFORME). But LibO now embeds even more fonts...