Bug 75561 - add selected object fill / stroke color
Summary: add selected object fill / stroke color
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-27 08:46 UTC by Mohith Manoj
Modified: 2018-04-10 18:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Implementing add color (34.64 KB, application/pdf)
2014-02-27 08:46 UTC, Mohith Manoj
Details
PPT file saved as ODP with few colored objects (14.31 KB, application/vnd.oasis.opendocument.presentation)
2014-03-01 03:56 UTC, Mohith Manoj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohith Manoj 2014-02-27 08:46:40 UTC
Created attachment 94803 [details]
Implementing add color

LO has a named list of colors that can be used as fill / stroke colors for all objects. A new color can be added through Tools > Options > Color.

However if I open a document (say a ppt) which has objects with colors not added to LO, I cannot save that color to the list of colors. The only way to use it is to use the copy format tool, won't be so convenient because it will change all formatting along with fill color.

Observation
On selecting an object who's fill / stroke colors are not added, the respective color picker drop down list on the menu bar automatically adds a new icon (with the selected object color) with an empty bracket pair '[]'.

New Feature Required
Provision to add the selected object's fill / stroke color on selecting it in the color selection drop down list in the menu bar.
Comment 1 Jean-Baptiste Faure 2014-02-28 05:42:18 UTC
Please could you attach your test document?

Best regards. JBF
Comment 2 Mohith Manoj 2014-03-01 03:56:30 UTC
Created attachment 94928 [details]
PPT file saved as ODP with few colored objects

File was originally created in MS power point.
Comment 3 Jean-Baptiste Faure 2014-03-01 15:44:19 UTC
Thank you for the test documents. I see the problem.
Valid enhancement proposition.

Best regards. JBF
Comment 4 Cor Nouws 2018-04-10 18:55:35 UTC
works with current color tools.
Select fist green shape, then red one, and notice that in the side bar, under recent colors for the background, green is available.