Download it now!
Bug 75605 - 4.2.1 double line cell borders print center line
Summary: 4.2.1 double line cell borders print center line
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-28 11:42 UTC by Buzz
Modified: 2015-06-20 11:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of form with table producing border errors (14.53 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-03-02 22:55 UTC, Buzz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buzz 2014-02-28 11:42:16 UTC
When using 4.2.1 my forms print incorrectly.

When formatting my cells with double lines as borders within a table, printing the form prints a single line as the border and adds a thin center line in the middle of the cell. 

I have had to re-install 4.2.0 so that I can print my forms correctly.
Comment 1 A (Andy) 2014-03-02 10:01:13 UTC
When I was trying to reproduce this issue I could observe a very buggy behavior and partly reproduce this reported issue (no double line on the screen and when printed).  
I could not reproduce the thin center line in the middle of the cell.
@Buzz: What have you done to reproduce this?

Steps Done:
1. Open WRITER
2. Go to INSERT -> TABLE and insert a new table (2x2)
3. Place the cursor inside the table
4. Go to TABLE -> TABLE PROPERTIES -> tab BORDERS
5. Change the LINE STYLE type to simple double line (ninth from the top, two thin lines), the LINE WIDTH is kept at 0.05 pt and then press OK

Interim Result:
No double line is visible, but a thicker single line.

6. Go to TABLE -> TABLE PROPERTIES -> tab BORDERS
7. Change the LINE WIDTH to 1.75 pt by using the arrow and please pay all the time attention to the LINE STYLE

Interim Result:
When changing LINE WIDTH from 1.5 pt to 1.75 pt, the LINE STYLE changes to a double line with one thin line and one thicker line.

8. Press OK

Interim Result: 
No double line visible, but single borders with thinner and thicker lines (thin lines at the top and on the left, thick lines at the bottom and on the right).

9. Go to TABLE -> TABLE PROPERTIES -> tab BORDERS
10. Change the LINE STYLE to two single thin lines (pay attention: the offered line styles have changed!) and press OK

Interim Result:
No double lines visible, but single borders with thinner and thicker lines (thick lines at the top and on the left, thin lines at the bottom and on the right).

11. Go to TABLE -> TABLE PROPERTIES -> tab BORDERS
10. Change the LINE WIDTH to 2.75 pt and press OK

Result: 
Double lines at the top and on the left, but no double line at the bottom and no correct double line on the right.
Comment 2 A (Andy) 2014-03-02 10:03:34 UTC
Sorry, forgot to mention: 
partly reproducible with LO 4.2.1.1 (Win 8.1)

numbering of the last step is of course "12" and not "10"
Comment 3 Buzz 2014-03-02 22:55:51 UTC
Created attachment 94987 [details]
Example of form with table producing border errors
Comment 4 Jean-Baptiste Faure 2014-03-03 05:45:57 UTC
Hi, there is some incoherence in this bug report. Indeed the component is Writer but the test document is a spreadsheet. As Writer and Calc do not handle the borders the same way, you should choose Cal or Writer for this bug report, and perhaps open a second bug report for the other component.

Set status to NEEDINFO. Please set back to NEW or UNCONFIRMED when the situation will be clarified.

Best regards. JBF
Comment 5 Buzz 2014-03-03 10:04:56 UTC
I have reset this bug component from writer to spreadsheet. 

Apologies for the confusion....Buzz
Comment 6 A (Andy) 2014-03-04 20:40:35 UTC
@Buzz: I can see them if I print your file (LO 4.2.1.1 / Win 8.1).  But could you please give more information about the different single steps to reproduce it, so that LO programmers can reproduce it in order to create a bug fix.
Comment 7 Buzz 2014-03-04 23:23:54 UTC
I formatted my forms many years ago using openoffice. I started using libreoffice about 2 years ago and have been printing them off every month.

If I remember correctly, I created a spreadsheet with just text in various cells, there were no sums or formulas. I selected certain columns and rows, right clicked - format cells - borders.

I then changed various border lines some with double line style. I can't remember if I also changed the width. Color black.

Hope this helps
Comment 8 Buzz 2014-03-05 10:16:17 UTC
A more description of the bug, relating to the above spreadsheet attachment.

In columns C F I every two cells should have a double line on top, when it prints, it prints it as a single line and adds a thin line in the center of the cell below where the double line should be.

There are a few other cells on the spreadsheet that have the same error.
Comment 9 Joel Madero 2015-05-02 15:40:58 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 10 Buovjaga 2015-06-20 11:02:38 UTC
Printed to PDF ok, WFM.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)