Download it now!
Bug 75632 - Impossibility to create a table with Autovalue primary key
Summary: Impossibility to create a table with Autovalue primary key
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-01 03:06 UTC by Desfontaine François
Modified: 2018-09-13 22:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
It's just a test to see if the setting of autovalue to Yes is maintained after saving (3.08 KB, application/vnd.sun.xml.base)
2014-03-05 13:06 UTC, Desfontaine François
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Desfontaine François 2014-03-01 03:06:11 UTC
FILE SAVE
I create a new table with an integer primary key. 
I set the Autovalue to Yes. 
I save the new table.
I open the table to create records.
The Autovalue of the primary key does not works.
If I edit the table the setting of the Autovalue is not to Yes but to No.

It is impossible to create a table with Autovalue primary key.
Comment 1 Robert Großkopf 2014-03-02 08:06:32 UTC
Which database do you use? If you chose the embedded Firebird-Database it doesn't work yet. It's Bug69949 . The embedded HSQLDB works here with AutoValue.
Comment 2 Desfontaine François 2014-03-03 09:01:51 UTC
I use HSQLDB.
The OS of my PC is Windows 7.
Comment 3 Robert Großkopf 2014-03-03 18:07:21 UTC
Can't confirm for OpenSUSE 12.3, 64bit rpm Linux, LO 4.2.1.1
Autovalue works as expected. Could create a table with it, could see the value. We must find someone with Win7, I think.
Comment 4 Regina Henschel 2014-03-04 19:05:30 UTC
I cannot confirm it. I have created a new database table with the embedded HSQLDB. The primary key has type INTEGER and autovalue works as expected, when opening the table.

How do you try to enter new records?

I work with Version: 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b on Windows 7 (32bit).

Can you please attach the .odb file, where autovalue does not work?
Comment 5 frofa 2014-03-05 09:53:45 UTC
Is this post relevant?
https://forum.openoffice.org/en/forum/viewtopic.php?f=13&t=67297
Comment 6 Desfontaine François 2014-03-05 13:06:45 UTC
Created attachment 95164 [details]
It's just a test to see if the setting of autovalue to Yes is maintained after saving

I have uninstalled the version 4.2.11 and installed the version 4.1.5.
The problem is the same : the setting of autovalue to yes is not maintened after saving the table.
I have on the same PC a Oracle VM Box with Debian installed and Libre Office. Autovalue works perfectly on this virtual machine.
Comment 7 Julien Nabet 2014-03-15 06:34:37 UTC
On pc Debian x86-64 with 4.2 sources updated some days ago, I don't reproduce the problem with the attachment and following comment 6.

I don't know how it could have an impact but just to be sure, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?
Comment 8 Julien Nabet 2014-05-30 23:04:06 UTC
François: any update here? BTW, there's now 4.2.4 LO version.
Comment 9 Thomas Hackert 2014-06-19 17:33:28 UTC
Hello Francois, *,
I cannot confirm your bug with LO Version: 4.3.0.1 Build-ID: 9ed0c4329cf13f882dab0ee8b9ecd7b05e4aafbb (parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel) with Germanophone lang- as well as helppack on Debian Testing i686, sorry ... :( Did you try to rename your profile, as Julien has recommended it to you in comment #7? Does it change anything? And which Java version are you using?
It would be nice, if you could answer our comments, so we can change the status back to unconfirmed ... ;)
Sorry for the inconvenience and have a nice evening
Thomas.
Comment 10 Desfontaine François 2014-06-21 12:51:43 UTC
Selon bugzilla-daemon@freedesktop.org:
Hello Thomas,
I have just found the solution to my problem.
In Tools/Options/LibreOfficeBase/Connexions/ActiveConnexionPool the port
com.sem.star.sdbcx.comp.hsqldb.Driver was set to yes.
Setting it to no was the solution to the problem.
Regards.
François

> https://bugs.freedesktop.org/show_bug.cgi?id=75632
>
> Julien Nabet <serval2412@yahoo.fr> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |NEEDINFO
>      Ever confirmed|0                           |1
>
> --- Comment #8 from Julien Nabet <serval2412@yahoo.fr> ---
> François: any update here? BTW, there's now 4.2.4 LO version.
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 11 Julien Nabet 2014-07-19 17:12:27 UTC
François: do you reproduce this with 4.2.6 LO version? Also, would you have some time to give a try to prerelease 4.3.0RC2? (see http://www.libreoffice.org/download/pre-releases/)

Lionel: put you in cc since you might be interested in this one.
Comment 12 Julien Nabet 2014-07-19 17:52:30 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
I noticed that when editing the table, the autovalue and other fields are disabled ("greyed") with pool connection for the driver enabled.
Would it be on purpose?
Comment 13 Alex Thurgood 2015-01-03 17:38:47 UTC
Adding self to CC if not already on
Comment 14 QA Administrators 2015-07-18 17:36:32 UTC Comment hidden (obsolete)
Comment 15 Desfontaine François 2015-07-20 08:03:10 UTC
As I had wroten in Comment 10 my problem is solved.
Now I use the 4.2.8.2 version without any more problem.
The setting of autovalue to yes is maintained after saving.
Comment 16 Robert Großkopf 2015-07-20 08:48:14 UTC
(In reply to Desfontaine François from comment #15)
> As I had wroten in Comment 10 my problem is solved.
> Now I use the 4.2.8.2 version without any more problem.
> The setting of autovalue to yes is maintained after saving.

So let us set this bug to "Resolved" and "Worksforme".
Comment 17 Julien Nabet 2018-09-13 22:18:14 UTC
I was giving a try to tdf#42905 that I could reproduce and found (again! since I was already in cc) this bug on Google searching "hsqldb autovalue".
1) Isn't it a dup?
2) ActiveConnexionPool is disabled by default and even if I enable it, com.sun.star.sdbcx.comp.hsqldb.Driver is already to NO and it doesn't work.

Did I miss something?