Bug Hunting Session
Bug 75745 - Custom Colors Should Appear at Front of List
Summary: Custom Colors Should Appear at Front of List
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other All
: medium enhancement
Assignee: Andreas Heinisch
URL:
Whiteboard: BSA
Keywords: needsDevEval
Depends on:
Blocks: Color-Picker-Widget Options-Dialog
  Show dependency treegraph
 
Reported: 2014-03-04 09:04 UTC by Chrisbath
Modified: 2019-07-24 08:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Custom colors (recently used colors) (29.97 KB, image/png)
2019-07-22 09:36 UTC, Andreas Heinisch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chrisbath 2014-03-04 09:04:02 UTC
This is not a bug but rather an enhancement request.
The addition of custom colors (Tools > Options > LibreOffice > colors) is possible and thank you but these colors are added at the end of list if they are personal, it is that the user wants to use and even probably more than standard colors.

My request is that the personal colors appear at the beginning of list.

Excuse me but I have not found under heading "enhancement request".

              
Operating System: All
Version: 4.2.1.1 release
Comment 1 A (Andy) 2014-03-04 22:58:36 UTC
marked as enhancement

But I personally have nothing against personal colors at the end.  For me it is ok to have them at the end of the list.

@Chrisbath: You are right it is not easy to find the option to mark it as an enhancement request.  This can be changed in the field Importance (change "normal" to "enhancement").
Comment 2 Joel Madero 2014-03-07 03:52:37 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date:   Tue Feb 25 19:58:48 2014 +0100 
Platform: Ubuntu Linux 13.10 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
IMPORTANCE


Note: I see no reason why we wouldn't do this - not going to impact many users (most aren't making custom colors) and I can see that if you're creating custom colors you may want them more visible.

P.S. In the future please make your titles reflect the request (thanks!)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 Björn Michaelsen 2015-05-19 13:01:12 UTC
add dev-list to cc for some EasyHacks ...
Comment 4 Robinson Tryon (qubit) 2015-12-10 07:59:01 UTC Comment hidden (obsolete)
Comment 5 Andreas Heinisch 2019-07-22 09:36:07 UTC
Created attachment 152899 [details]
Custom colors (recently used colors)
Comment 6 Andreas Heinisch 2019-07-22 09:37:27 UTC
Is this still valid? In the screenshot there you find all colors in the recently used colors list.
Comment 7 V Stuart Foote 2019-07-22 23:30:00 UTC
The juxtaposition of the 'Custom colors' and 'Document colors' palettes with the color swatch box of 'Recent' used colors make much of this irrelevant.

The Custom colors palette entries will be written to user profile, while the Document colors are recorded into the ODF and are _added to the start_ of the Recent colors swatch bar when a saved document (or better a Template) is reopened.

IMHO => WFM
Comment 8 Andreas Heinisch 2019-07-23 10:36:23 UTC
Should we close this bug since it is not relevant anymore?