Bug 75825 - Other: "Send Document as E-Mail" not working -- (while sending as attachment works)
Summary: Other: "Send Document as E-Mail" not working -- (while sending as attachment ...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-06 08:14 UTC by Christian Gonzalez
Modified: 2015-05-05 20:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Gonzalez 2014-03-06 08:14:39 UTC
Problem description: 

Steps to reproduce:
1. write a document, save it as testdocument.odt anywhere
2. choose File->Send->Document as E-mail

Current behavior:
Thunderbird opens (configured as default in Ubuntu) with the message composer, the mail title says "testdocument.odt", but the message body is empty. Same when choosing File->Send->"E-mail as OpenDocument-text" or "E-mail as Microsoft Word". No attachment is generated,


Expected behavior: Document text should appear as message body, or as attachment.

              
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 Christian Gonzalez 2014-03-06 08:21:52 UTC
Additional info: maybe it's not a bug in LO, but in Ubuntu, or in Thunderbird - I can't tell that from my POV.
Comment 2 Christian Gonzalez 2014-03-06 08:31:40 UTC
The downstream bug in Ubuntu seems to be https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1217191.
Either the sensible-louma command is broken, or should be replaced. So maybe this is an Ubuntu packaging bug?
Comment 3 Stephan Bergmann 2014-03-07 08:36:44 UTC
This is apparently a Ubuntu-specific problem.  Neither TDF nor other distros' (e.g., Fedora) builds have a "sensible-louma".
Comment 4 Björn Michaelsen 2014-03-07 09:59:08 UTC
nitpicks: its sensible-lomua and Debian has it too. ;)
Comment 5 sophie 2014-03-07 10:27:47 UTC
Hi, I tried to reproduce using Debian 6, LibreOffice 4.1.5.3 and Mutt and the document is shown as attachment and sent correctly. Sophie
Comment 6 Marina Latini (SUSE) 2014-03-07 10:40:18 UTC
Hi, 
I tried to reproduce using openSUSE Tumbleweed, LibreOffice 4.1.4.2 (build id 410m0 build2) and Kmail.
The document is shown as attachment, the subject is the file name.
Comment 7 Björn Michaelsen 2014-03-17 08:49:43 UTC
So I tested on Ubuntu (without sensible-lomua) with LibreOffice 4.2.3 and gentoo with LibreOffice 4.1.4:
- Ubuntu trusty/LibreOffice 4.2.3: "Send Document as Email" doesnt work, while "Send Document as OpenDocument Text" works
- gentoo/LibreOffice 4.1.4: "Send Document as Email" doesnt work, "Send Document as OpenDocument Text" doesnt works

For "Send Document as Email" I would expect the text body to appear in the mail body. That doesnt happen on both distros, so likely an upstream issue. For Send Document as OpenDocument Text" I would expect it to be attached, which happens just fine on Ubuntu/LO 4.2 without sensible-lomua.

Limiting this issue on the "Send Document as Email" part ONLY, as it happens on multiple distros. Please file a separate bug for "Send Document as OpenDocument Text" if that also happens.
Comment 8 Stephan Bergmann 2014-03-17 09:42:54 UTC
(In reply to comment #7)
> For "Send Document as Email" I would expect the text body to appear in the
> mail body. That doesnt happen on both distros, so likely an upstream issue.

Writer "File - Send - Document as E-mail..." does create a mail with the document as attachment here (various LO versions, running on Fedora 20).  It spawns program/senddoc, passing --mailclient, --subject, and --attach arguments, I'd suggest to start debugging there.
Comment 9 Björn Michaelsen 2014-03-17 16:55:45 UTC
But if "Send Document as E-Mail" and "Email as OpenDocument Text" do the same, why do we have two menu entries anyway? Shouldnt we just kill "Send Document as E-mail and only keep the explicit "E-mail as $FORMAT" ones?
Comment 10 Björn Michaelsen 2014-03-17 17:42:24 UTC
Or to put it different: Whats the difference between .uno:SendMail and .uno:SendMailDocAsOOo and for what do we need the former in Writer?
Comment 11 Björn Michaelsen 2014-03-19 13:45:31 UTC
(In reply to comment #7)
> - Ubuntu trusty/LibreOffice 4.2.3: "Send Document as Email" doesnt work,
> while "Send Document as OpenDocument Text" works

Hmm, most strange. I just retested 4.2.3 from Ubuntu after killing sensible-mua and cant reproduce anymore. Closing as NOTOURBUG as the problem likely persists on Debian, which keeps sensible-mua (also CCing Rene for that).
Comment 12 Markus Küpper 2014-09-28 10:34:18 UTC
Neither does "Send Document as Email" nor "Send OpenDocument spreadsheet file as Email" work. The result is just an email with the file name as subject, but no document attached.

Debian jessie/sid 
LibreOffice Version: 4.3.1.2 Build-ID: 430m0(Build:2)
Icedove 31.0
Comment 13 Charu Tyagi 2015-01-07 09:43:02 UTC
I have pushed a patch that fixes the issue. The link to the patch is : https://gerrit.libreoffice.org/#/c/13786/
Comment 14 bruno 2015-03-31 22:50:53 UTC
This is not sufficient in my case as gconftool-2 returns a full path name, so I modified that with: if [ "`basename $client`" = "thunderbird" ]; then

which works, even if it doesn't solve my issue https://bugs.documentfoundation.org/show_bug.cgi?id=90382
Comment 15 bruno 2015-05-05 20:59:37 UTC
In fact after more tests, this is indeed fully fixing the issue I had (but I need that basename added)