Bug 76006 - LibO Stable incorrectly refers to release 4.1.4; also points to nightly builds that belong on the LibO Fresh page
Summary: LibO Stable incorrectly refers to release 4.1.4; also points to nightly build...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-11 00:37 UTC by V Stuart Foote
Modified: 2015-05-02 17:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The LibreOffice Stable download page with questionable text and incorrect 4.1.4 reference (161.22 KB, image/jpeg)
2014-03-11 06:05 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2014-03-11 00:37:07 UTC
The **NEW** LibreOffice downloads page looks great!

However, a couple of glaring errors--or just plain confusing ;-)

The LibreOffice Stable landing page incorrectly refers to release 4.1.4. And this paragraph seems mispositioned on the page.

Text on the Stable page also points to "nightly builds" as "more bleeding-edge binaries" believe that reference logically belongs on the LibreOffice Fresh page.

Stable should point to Fresh--and from Fresh refer folks to the nightly development builds.
Comment 1 V Stuart Foote 2014-03-11 00:47:30 UTC
And a further note... the text/links for the Development versions ( http://www.libreoffice.org/download/development-versions/ ) has gone a bit stale. 

Is currently referring to 4.2.0 RC1 and 4.1.4 RC2--just a bit dated.
Comment 2 tommy27 2014-03-11 05:58:28 UTC
(In reply to comment #0)
> ....
> The LibreOffice Stable landing page incorrectly refers to release 4.1.4. 

I see 4.1.5 here http://www.libreoffice.org/download/libreoffice-stable/

> Text on the Stable page also points to "nightly builds" as "more
> bleeding-edge binaries" believe that reference logically belongs on the
> LibreOffice Fresh page.

I agree.

> And a further note... the text/links for the Development versions (
> http://www.libreoffice.org/download/development-versions/ ) has gone a bit
> stale. 
> 
> Is currently referring to 4.2.0 RC1 and 4.1.4 RC2--just a bit dated.

I confirm this.
Comment 3 V Stuart Foote 2014-03-11 06:05:51 UTC
Created attachment 95570 [details]
The LibreOffice Stable download page with questionable text and incorrect 4.1.4 reference

screen clip with paragraph needing adjustment attached...
Comment 4 tommy27 2014-03-11 06:45:30 UTC
Ok you are right.
the download button correctly refers to 4.1.5 but the text is still about 4.1.4
Comment 5 V Stuart Foote 2014-03-11 06:47:23 UTC
Just looked around a bit more, and was a bit surprised to see the 'Release Notes' ( http://www.libreoffice.org/download/release-notes/ ) are very out of date--showing details that were current for the 4.2.0 (Jan 27, 2014) and 4.1.4 (Dec 16, 2013) releases.

Design of the page looks great, but the content NEEDS to be brought (and kept) current to match the releases being delivered, i.e. currently 4.1.5 (Feb 10, 2014), 4.2.1 (Feb 17, 2014) and the pending release of 4.2.2 (build complete as of Feb 27, 2014).

Not a Wiki so I can't post the changes myself, but happy to help with the editing if someone sends along the publishing procedure and contact(s).
Comment 6 Joel Madero 2015-05-02 15:44:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02