Download it now!
Bug 76049 - FILEOPEN - Corrupted database on Truecrypt volume
Summary: FILEOPEN - Corrupted database on Truecrypt volume
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-12 01:51 UTC by doctorsys
Modified: 2015-09-04 03:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description doctorsys 2014-03-12 01:51:56 UTC
I have created a database twice on a Truecrypt volume and both times, when I unmount and then remount the TC volume, opening the ODB file starts it in Writer with unintelligible text.  While the volume is mounted, I can create the database, save it and exit and then open the database again fine.  The ODB file appears to get corrupted by the encryption when the volume is unmounted.  I have tried resetting my profile but that didn't help.  ODB files on non-encrypted drives work fine so it is not my installation.

Is this a bug or is there a work-around for this?

DS
Comment 1 Terrence Enger 2014-08-22 00:41:00 UTC
doctorsys,

I am wondering if this bug report is still interesting to you, in view
of the fact that TrueCrypt is now unsupported and its maintainers
recommend that users find another solution.

Terry.
Comment 2 Alex Thurgood 2015-01-03 17:40:59 UTC
Adding self to CC if not already on
Comment 3 QA Administrators 2015-07-18 17:35:35 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 4 QA Administrators 2015-09-04 03:00:55 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Message generated on: 2015-09-03