Bug Hunting Session
Bug 76085 - VIEWING: view --> page break preview while multiple sheets selected
Summary: VIEWING: view --> page break preview while multiple sheets selected
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 76086 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-12 18:30 UTC by Ahamed
Modified: 2016-04-18 07:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of pagination with "Page Break" view (220.77 KB, image/png)
2016-04-18 07:26 UTC, mahfiaz
Details
Screenshot of printing dialog (90.45 KB, image/png)
2016-04-18 07:27 UTC, mahfiaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ahamed 2014-03-12 18:30:16 UTC
TWO bugs of the same nature:

1)I feel the page-break view has a bug in that : suppose there are only two sheets and both have only one page each in them and when we select all the two sheets the page break view should re-designate the water marked page number revised to reflect the selected sheets and its order ie. the 2nd sheet page should be "Page 2" ......... instead of " Page 1" and it should be accordingly reflected as many sheets and pages are there ...........

2) The pages while in the page break preview lists the pages 1 to n depending upon the order vertically or horizontally.  But when the page-break-preview it should reflect the page number from which we suppose to start with ie. instead of starting with a page no. of 1 suppose we put 4 and tick mark the Format--> Page Style --> Sheet --> First page Number selection, then it should be pages 4 to n+3 





              
Operating System: All
Version: 4.1.0.4 release
Comment 1 Jean-Baptiste Faure 2014-03-13 05:25:27 UTC
*** Bug 76086 has been marked as a duplicate of this bug. ***
Comment 2 Jean-Baptiste Faure 2015-08-01 19:23:04 UTC
Hmm, the point of this bug report seems clear for nobody.
Please attach a test document and describe step by step how to reproduce the problem.

Best regards. JBF
Comment 3 mahfiaz 2016-04-18 07:26:20 UTC
Created attachment 124446 [details]
Screenshot of pagination with "Page Break" view

To reproduce:
1) Have 2 worksheets
2) Fill both in with data so that it would not fit two pages
3) View → Page break to see pagination
4) Admire your hard work or just open the attached screenshot.

Requests in order:
1) The page numbers on sheet 2 should continue from where they ended on sheet 1. (Notice the gray "Page 1" should in this case be "Page 2" or more).

2) It should also take into account the "First page number" in Format → Page dialog. So the number in screenshot should be "Page 5" or more.


What we need to consider is that page numbers depend on the amount of sheets printed. If for "Range and Copies" you select "All sheets" the first page number (usually 1) will be on sheet 1. If you print "Selected sheets" (by default) it may as well be on any other page.

It's not a technical question whether the page numbers in print should start from 1 for a new sheet or continue the numeration. Right now the user can have it both ways.

I think the current behaviour is just fine, because there is no good way to know in advance if the user is going to print all sheets or only selected sheets.
Comment 4 mahfiaz 2016-04-18 07:27:03 UTC
Created attachment 124447 [details]
Screenshot of printing dialog
Comment 5 mahfiaz 2016-04-18 07:39:39 UTC
For the reasons stated above I will mark this as resolved, wontfix.

(The reason was it is right now not possible to know before printing which numbers we should be showing.)