Download it now!
Bug 76128 - FORMATTING: Calc Page Style Scaling Mode
Summary: FORMATTING: Calc Page Style Scaling Mode
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, bisected, regression
: 87609 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-13 17:17 UTC by Chris Mayoros
Modified: 2018-06-13 09:42 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Mayoros 2014-03-13 17:17:38 UTC
Problem description: 
When you go to the page formatting options, and set the scaling mode to "Fit print range(s) to width/height" it used to allow the option to set either the width or height to a blank. I have set many spreadsheets to fit 1 page wide by as many pages as needed high. Now it no longer offers this option, if you try to leave either one blank, it automatically puts a 1 in there.

Steps to reproduce:
1. Go to Format->Page
2. Click the Sheet tab
3. Change Scaling mode to "Fit print range(s) to width/height"
4. Attempt to leave either option blank.

Current behavior:
Fills the field with a "1"

Expected behavior:
One of the fields should be able to be left blank, meaning as many pages as needed.
Operating System: Ubuntu
Version: 4.2.0.4 release
Comment 1 Joel Madero 2014-05-01 03:59:23 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.3.0.0.alpha0
Date:   Thu Apr 24 21:43:16 2014 +0300
Platform :Ubuntu 14.04
DE: GNOME3

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Minor - not going to prevent high quality work but can slow you down quite a bit + doesn't seem to be a highly popular feature (no additional comments in 6+ weeks)
High - regression

Keywords - regression (broken in 4.3, works fine in 3.6 and 4.0beta, trying to narrow down more)

@Chris - if you happen to know the last working version that would be useful info. Thanks!

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Chris Mayoros 2014-05-01 05:48:42 UTC
Thank you for confirming the report. I just installed LibreOffice 4.1.5.3 inside an Ubuntu 12.04 virtual machine. It has the problem. I cannot change either the height or width in pages option to a blank on it. I cannot find any older versions to download & test with.
Comment 4 Chris Mayoros 2014-05-02 03:07:33 UTC
Thank you very much for sending me the link. Here's the results of my testing:

version 4.0.6.2 works correctly.

version 4.1.0.0.beta1 has the issue.
Comment 5 raal 2014-08-19 07:39:15 UTC
c4dc144d0650a2a89e870d4906a68db5b2bc6769 is the first bad commit
commit c4dc144d0650a2a89e870d4906a68db5b2bc6769
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Oct 16 21:38:00 2013 +0000

    source-hash-ae2c256e228b3d4d01e85abdbc797a907c7f6563
    
    commit ae2c256e228b3d4d01e85abdbc797a907c7f6563
    Author:     Michael Meeks <michael.meeks@suse.com>
    AuthorDate: Thu Apr 4 11:07:54 2013 +0100
    Commit:     Michael Meeks <michael.meeks@suse.com>
    CommitDate: Thu Apr 4 11:17:21 2013 +0100
    
        unwind tangled mess around spinner buttons
    
        Restore removed spinner artwork, cleanup the code: hicontrast - is now
        a function of icon theme, not a global boolean.
        uwith thanks to Ariel Constenla-Haile)
    
        Change-Id: I68d4c7293a6faa130274cf45f53509ce140fa8c0

:100644 100644 64d261b4291fe444b80068efa8911fe6b2d62e7d f1265c5592105896d12b1acb60ce6b5b04318cf7 M	ccache.log
:100644 100644 0b4a914f04a25007e396a9398d9f1ccd2ff689d1 54518cbaf493226017cacae67abaa92694a1ecc0 M	commitmsg
:100644 100644 2258d830f9c06110ec7004b59574916d64024245 4946aa0976b2dd0df91f98c690c4d08a0738b355 M	dev-install.log
:100644 100644 bfefb4eceaffb811fd32c0d72218e57a26e19dc7 814670879f955c5889813fad0a77ac18ba8cf972 M	make.log
:040000 040000 a49659521c914bc0c75affec1b7e1c4373849fe6 af916437809240a7ac146739a7ff8a6aaa7ab543 M	opt


git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect good 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# bad: [8ad82bc1416a07501651e8d96fe268e47d3931d3] source-hash-13821254f88d2c5488fba9fe6393dcf4ae810db4
git bisect bad 8ad82bc1416a07501651e8d96fe268e47d3931d3
# good: [238338bc4111eb82429ea47384d4012bcd7cdc3e] source-hash-b6ba04639b9922f6717f79ac4be215e09691d7a9
git bisect good 238338bc4111eb82429ea47384d4012bcd7cdc3e
# good: [f24a67989fadc0affdfed9edf28f2f59fd6c279f] source-hash-930fe0581794e2ae6aaa62c2c716ed655a0f2885
git bisect good f24a67989fadc0affdfed9edf28f2f59fd6c279f
# good: [2a05be5f2465d8bf3a527ebbee1884df2b967f43] source-hash-52770659d33f8f08a769043392cfb5a926019fef
git bisect good 2a05be5f2465d8bf3a527ebbee1884df2b967f43
# bad: [c4dc144d0650a2a89e870d4906a68db5b2bc6769] source-hash-ae2c256e228b3d4d01e85abdbc797a907c7f6563
git bisect bad c4dc144d0650a2a89e870d4906a68db5b2bc6769
# good: [5c854a34fd0d2bb0c91532cf1d9a5159a43538af] source-hash-1e1ac3ba37de4aaab3e7fada378ecd73ee2f5b6c
git bisect good 5c854a34fd0d2bb0c91532cf1d9a5159a43538af
# first bad commit: [c4dc144d0650a2a89e870d4906a68db5b2bc6769] source-hash-ae2c256e228b3d4d01e85abdbc797a907c7f6563
Comment 6 Robinson Tryon (qubit) 2014-11-20 18:08:04 UTC Comment hidden (obsolete)
Comment 7 Michel Rudelle 2014-12-10 13:00:15 UTC
Hi, a workaround is to put a large number instead of a blank, but it is not very pleasant.
Fortunately, the old spreadsheets work properly but only if you do not change any formatting option in the page style. Reason why I hope this can be repair soon
Best regards
Comment 8 sophie 2014-12-23 10:53:02 UTC
*** Bug 87609 has been marked as a duplicate of this bug. ***
Comment 9 Matthew Francis 2015-01-07 15:28:35 UTC
The behaviour changed in the below commit.

Adding Cc: to olivier.hallot@documentfoundation.org. Could you possibly take a look at this? Thanks


commit cb553bdba77c80f323dbed1874874cf2465abd83
Author: Olivier Hallot <olivier.hallot@alta.org.br>
Date:   Sun Mar 31 14:52:34 2013 -0300

    Convert Calc sheet page style to Widget UI
    
    Change-Id: I6714ccc710d266a047032166c738063602e6e30d
    Reviewed-on: https://gerrit.libreoffice.org/3140
    Reviewed-by: Caolán McNamara <caolanm@redhat.com>
    Tested-by: Caolán McNamara <caolanm@redhat.com>
Comment 10 Chris Mayoros 2015-08-07 00:04:14 UTC
Just upgraded to the new LibreOffice 5.0. It's still having the same issue.
Comment 11 Robinson Tryon (qubit) 2015-12-13 11:16:14 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2016-09-26 15:36:59 UTC
Adding Cc: to Olivier Hallot
Comment 13 Markus Mohrhard 2016-10-05 01:00:29 UTC
The easiest way to handle this seems to be a radio button next to the spin fields.

Adding UX team for a solution.
Comment 14 Heiko Tietze 2016-10-05 07:28:13 UTC
What we have is 
* Reduce/enlarge printout
  + 100% means original = default
  + > or < 100% is what the label states
* Fit to width/height
  + width or height set to a high number fits the content accordingly
  + width or height to a reasonable number defines precisely the export
* Fit to a number of pages
  + takes the height into account for the number of pages

Thinking about fit to n pages makes me wonder if it's possible to have a certain width _and_ height at the same time. And if these options are exclusively we could have the scaling options like this

( ) Don't scale
(o) Fit width to 1/n pages
( ) Fit height to 1/n pages
( ) Scale proportionally to 100/n %

The 'do not scale' convenience option is for users who don't want to meditate about what happens in case of 100%.
Numerical stepper allow to set a maximum. Showing the number of pages in respect to the alternative option as default could be helpful.

In a second thought the exclusive nature of width/height is not so clear anymore. But I'd still make the choice as simple as possible. Users who want to scale in both dimensions have the proportional option.
Comment 15 Charles 2017-01-06 16:06:48 UTC Comment hidden (obsolete)
Comment 16 Charles 2017-01-06 16:07:16 UTC
Just bumped into this myself.

Would appreciate it being fixed. I don't use it often, but when I need it, it is very annoying not to have it work as expected.

Libreoffice 5.2.4 on Windows 7 x64
Comment 17 Heiko Tietze 2018-06-13 09:42:53 UTC
There are checkboxes in 6.0 to set width or height as unspecified. Guess this solves the issue. Please reopen if not.