Bug 76135 - FILESAVE: frame w/ figure and caption saved as docx crashes MS word
Summary: FILESAVE: frame w/ figure and caption saved as docx crashes MS word
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 76136 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-13 18:39 UTC by Juang Dse
Modified: 2014-03-13 22:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
document with figure (7.44 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-03-13 18:39 UTC, Juang Dse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juang Dse 2014-03-13 18:39:41 UTC
Created attachment 95735 [details]
document with figure

Problem description: 

Steps to reproduce:
1. insert picture with autocaption on
2. save document as docx
3. load document in MS word (windows 7)

See attached example.

Current behavior: crash of MS word

Expected behavior: no crash

Operating System: Linux (Other)
Version: 4.2.0.4 release
Comment 1 Jean-Baptiste Faure 2014-03-13 18:55:17 UTC
Hmmm, if MS-Word crashes when opening a file is a bug of MS-Word, not of LibreOffice, even if this docx file generated by LibreOffice would not be a valid OOXML file. 
And a crash in MS-Word does not prove that this file is not a valid OOXML file.
Note: you do not say which MS-Word crashes, it is important because only MS-Word 2013 implements the standard OOXML, previous MS-Word versions implement only transitional OOXML which is not the ISO standard.

Closing as NotOurBug. Please feel free to reopen if you have an independent proof that this file is not a valid OOXML file.

Best regards. JBF
Comment 2 Juang Dse 2014-03-13 22:04:54 UTC
*** Bug 76136 has been marked as a duplicate of this bug. ***