Bug Hunting Session
Bug 76282 - EDITING: [RFE] Ability to disable character-substitution in paragraph-styles
Summary: EDITING: [RFE] Ability to disable character-substitution in paragraph-styles
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-17 17:31 UTC by David Juran
Modified: 2017-08-03 13:49 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Juran 2014-03-17 17:31:23 UTC
Problem description: 
When writing a technical document, I often have sections which are intended to be cut-and-pasted into a terminal window. For these sections I use a specific paragraph style.
 LibreOffice by default does certain character substitutions such as replacing "--" with a long line. This does look good in the text so I wouldn't want to disable the substitution altogether but it's suboptimal when the intention is that the text should be pasted into a terminal and then some command-line option has gotten substituted into something that the terminal interprets as a control code and goes berserk...

I therefore propose that it should be possible to disable character substitutions in a paragraph style.



              
Operating System: Fedora
Version: 4.2.1.1 release
Comment 1 sophie 2014-03-17 18:00:13 UTC
You can disable this under Tools > AutoCorrect Options > Options > uncheck the options you don't want. 
Set as worksforme, please reopen if it doesn't solve your problem - Sophie
Comment 2 David Juran 2014-03-17 18:41:27 UTC
I do realize that auto-correct options can be disabled, but rather then disabling them for an entire document, I would like to disable them only in a paragraph style. So that when I'm writing this particular paragraph style, the autocorrection is disabled but for the rest of the document it should be enabled.
Comment 3 Joel Madero 2014-11-06 00:20:58 UTC
From what I can see this was never confirmed by QA team - moving to UNCONFIRMED to get their confirmation.
Comment 4 Robinson Tryon (qubit) 2014-12-21 22:53:13 UTC
(In reply to David Juran from comment #2)
> I do realize that auto-correct options can be disabled, but rather then
> disabling them for an entire document, I would like to disable them only in
> a paragraph style.

Disabling auto-correct for a single paragraph seems plausible enough.

Status -> NEW

UX: I'm tossing this one over to you as you might want to have some input here.
Comment 5 David Juran 2014-12-24 10:46:24 UTC
If I could have a wish, I would not only like to disable it paragraph-by-paragraph, but also in a paragraph style.
Comment 6 Jean-Francois Nifenecker 2014-12-31 06:30:03 UTC
Please note that pressing Ctrl+Z immediately after the substitution has been made will undo it. This behaviour seems ok to me.
Comment 7 Robinson Tryon (qubit) 2016-08-25 04:21:40 UTC Comment hidden (obsolete)
Comment 8 Heiko Tietze 2017-08-03 12:50:12 UTC
The design team discussed the request. While the idea is tempting to have a paragraph style like "code" and to (un)link that style with the auto correction feature, it is a rather complex workflow. The UI gets much more difficult for only a few situations. On the other hand it's very easy to manually disable auto correction (Tool > AutoCorrect > While Typing). (Customization of a shortcut for this function is not difficult.) Plus, undo is also an option.

So we recommend to not implement this feature.
Comment 9 Regina Henschel 2017-08-03 13:49:45 UTC
(In reply to David Juran from comment #0)
> Problem description: 
> When writing a technical document, I often have sections which are intended
> to be cut-and-pasted into a terminal window. For these sections I use a
> specific paragraph style.
>  LibreOffice by default does certain character substitutions such as
> replacing "--" with a long line. This does look good in the text so I
> wouldn't want to disable the substitution altogether but it's suboptimal
> when the intention is that the text should be pasted into a terminal and
> then some command-line option has gotten substituted into something that the
> terminal interprets as a control code and goes berserk...

Such substitutions are bound to language. You only need to set the language to [none] in your special paragraph style and e.g. -- and " will stay as they are typed. I use a monospaced font in addition.