Bug 76288 - Frequent crashes in libreoffice, particularly using zotero extension.
Summary: Frequent crashes in libreoffice, particularly using zotero extension.
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-17 19:24 UTC by LooseSpokes
Modified: 2014-05-28 18:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Backtrace from when using Extension Manager triggered freeze/ Libre OFfice to Hang (25.79 KB, text/x-log)
2014-05-12 10:29 UTC, LooseSpokes
Details
Backtrace from when LibreOffice crashed when saving (17.84 KB, text/x-log)
2014-05-12 10:30 UTC, LooseSpokes
Details
Further Backtrace from when LibreOffice crashed when saving (21.16 KB, text/x-log)
2014-05-12 10:31 UTC, LooseSpokes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LooseSpokes 2014-03-17 19:24:06 UTC
Hi, I've been getting frequent crashes on libreoffice, and losing work. I've detailed these in a bug report to the debian bugtracker here which details them: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=737326 . I've also been getting the problem when saving files, as detailed in the bug report here: https://bugs.freedesktop.org/show_bug.cgi?id=76233

I've been getting a particular problem using the zotero integration. Most of the time it works okish, adding references and bibliographies etc. but sometime it crashes. However, one crash I've been getting *every time* and reproducibly is when trying to remove field codes (there's a button for this in the zotero extension). I've detailed this in full on the zotero forums bug tracker including several reports and error messages: https://forums.zotero.org/discussion/35423/report-ids-1803874051-1803874051--libre-office-crashes-using-zotero-integration-plugin/#Comment_183560

(Also possibly related, I get crashes when going to the extension manager in libreoffice - this is also reproducible every time; full details here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=731052)

Apologies for the posting of so many links but didn't want to duplicate stuff that had already been detailed a lot! Would be very grateful if this could be fixed and if there is any way I can sort this out on my system now.

Cheers.
Comment 1 Julien Nabet 2014-03-17 20:32:59 UTC
You seem to have quite a lot of bugs with extensions.

You could try this:
- backup your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux)
- remove LO and LO extensions packages (with conf purge option)
- install LO without extensions
- give it a try
- if ok, install one by one the other extensions from your distrib repo and give a try after each install

Keep us informed :-)
Comment 2 LooseSpokes 2014-03-19 17:41:41 UTC
OK thanks - i've tried this and it worked fine, apparently, until I installed the zotero plugin integration from the debian testing repo (haven't tried the other plugins - didn't really use them).

As soon as I did this, I tried a) saving - and managed to get it to crash doing this, and then b) going to extension manager - again, trying the update option got it to crash. I also tried c) remove field codes, and it crashed, as before.
Comment 3 LooseSpokes 2014-03-19 17:45:26 UTC
OK thanks - i've tried this and it worked fine, apparently, until I
installed the zotero plugin integration from the debian testing repo
(haven't tried the other plugins - didn't really use them).

As soon as I did this, I tried a) saving - and managed to get it to
crash doing this, and then b) going to extension manager - again, trying
the update option got it to crash. It also crashed as before when I
tried 'remove field codes' in the zotero integration.
Comment 4 Julien Nabet 2014-03-19 20:21:11 UTC
Please don't answer directly from your emailer but from this link:
https://bugs.freedesktop.org/show_bug.cgi?id=76288#

Then it seems a bug in the extension not in LO.
Comment 5 LooseSpokes 2014-03-20 14:35:37 UTC
Ok, sorry for the duplicate emails. Zotero suggested that since the crashing was in libreoffice I should report it to you: https://forums.zotero.org/discussion/35423/report-ids-1803874051-1803874051--libre-office-crashes-using-zotero-integration-plugin/

So an interesting update – I logged out of KDE and into Gnome (on the same system – I have both installed though generally only use KDE) – and tried the same things in libreoffice, and it is working fine – inserting citations, removing field codes, etc.

(a strange problem is that when I try it in gnome, with zotero standalone, rather than iceweasel/firefox open, and add a citation, it says:

“OpenOffice.org could not communicate with Zotero. Please ensure Firefox or Zotero Standalone is open and set to an online state and try again.”)

It could relate to themes I guess, there was another zotero bug relating to the gtk theming in KDE, but I'm not sure how far that applies to libre office?
Comment 6 Julien Nabet 2014-03-20 20:28:50 UTC
You could retrieve a backtrace from the crash of LibreOffice by following this link:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
It might help to determine the responsability.
Comment 7 LooseSpokes 2014-03-23 16:00:19 UTC
Ok thanks - will try that. Might be a few weeks though as I've got some urgent deadlines coming up.

I've tried to get a backtrace previously and found it pretty confusing, so might have to post here with some questions if i get into difficulties!
Comment 8 LooseSpokes 2014-05-12 10:29:12 UTC
Created attachment 98896 [details]
Backtrace from when using Extension Manager triggered freeze/ Libre OFfice to Hang
Comment 9 LooseSpokes 2014-05-12 10:30:14 UTC
Created attachment 98897 [details]
Backtrace from when LibreOffice crashed when saving
Comment 10 LooseSpokes 2014-05-12 10:31:14 UTC
Created attachment 98898 [details]
Further Backtrace from when LibreOffice crashed when saving
Comment 11 LooseSpokes 2014-05-12 10:37:23 UTC
Hi, please find attached my attempts at getting a backtrace relating to this bug (or bugs). I was trying to get a bug report of the specific crash relating to removing field codes in zotero but I'm not sure that any of these bug reports are that.

Whilst the specific aspects of this bug relating to Zotero, and in the extension manager, only appeared when using Libre Office in KDE, I still got irregular crashes when using it in Gnome.

Shortly after I'd got these backtraces, my laptop irreparably stopped working (motherboard?) and I'm now using a new one - with Kubuntu 14.04 - I don't seem to be getting these errors on this. I failed at installing Debian on this machine so there's no chance of me testing this further.

Thanks for your help.
Comment 12 Joel Madero 2014-05-16 21:14:58 UTC
This bug has to be migrated over to redmine as we aren't responsible for third party extensions. CC'ing Andreas so he can move it.
Comment 13 Julien Nabet 2014-05-28 18:54:04 UTC
Following Joel's comment, put it NOTOURBUG