Bug Hunting Session
Bug 76346 - FORMATTING: the page number in the view-> page break preview does not show correctly
Summary: FORMATTING: the page number in the view-> page break preview does not show c...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-19 07:30 UTC by Ahamed
Modified: 2015-05-24 13:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
PageBreak.ods example (10.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-05-24 13:53 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ahamed 2014-03-19 07:30:48 UTC
Problem description: 
The page number in the view-> page break preview  does not show correctly.  suppose there are two sheets only and in each sheet contain THREE pages of data only. while in sheet 2 then select the first sheet also using CTL button pressed or SHFT button pressed, then in the second sheet page number should reflect the page number considering the whole two sheets ie. it should start the page number from 4 then 5 and then 6 etc.

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:
the page number shows only 1 2 3 etc, not 4 , 5 and then 6
Expected behavior:
it should show  4 , 5 and then 6
(THIS should be the case when the first page number is insisted to get started with yet another number say 10 then the page numbers should reflect 11 then, 12 and then 13 etc.              
Operating System: All
Version: 4.1.1.2 release
Comment 1 Ahamed 2014-03-19 07:33:38 UTC
Also I wish to have a pageNo() function something similar to that in 
http://www.oraxcel.com/projects/litlib/ for MS office
Comment 2 Ahamed 2014-03-19 07:36:28 UTC
Also  I wish to have the pageNo() function something similar to that is available in MS Office through http://www.oraxcel.com/projects/litlib/
Comment 3 A (Andy) 2014-03-22 10:25:35 UTC
For me not reproducible with LO 4.2.2.1 (Win 8.1), the page numbers are shown correctly on my computer.
Can anybody else with LO 4.1 confirm this bug?

Regarding your second comment you should please open another bug report (enhancement request).
Comment 4 sophie 2014-03-24 13:18:26 UTC
I can confirm what you say either on 4.1.5.3 and for 4.2.3.1. But it's not a bug, the numbers that you see are an indication on how the pages break on one sheet, it's not a page numbering, it's only a preview of how the pages are disposed on a given sheet. The order of numbering is set in the Format > Page > Sheet tab. 
Closing as worksforme - Sophie
Comment 5 Ahamed 2014-03-28 16:59:58 UTC
Hi all,
Pl. see that the behaviour in the page-break-preview is  ideal for SINGLE sheet but not for multi sheet calc documents.  Even if it(ie. behaviour of page-break-preview) is similar to  MS EXCEL, it does not mean that it is not a bug.  Actually it is a bug. ie. it does not give the correct page number in the doc page-break-view.   

please bear with me.............

Hence I am reopening it again 

Ahamed
Comment 6 Ahamed 2014-03-28 17:03:06 UTC
continuing again,

please see that the page-break-PREVIEW is NOT only the page break preview but IT DOES include the page NUMBER as well.

Ahamed
Comment 7 Joel Madero 2014-11-02 16:27:21 UTC
Never confirmed by QA team - moving back to UNCONFIRMED.
Comment 8 pierre-yves samyn 2015-05-24 13:52:07 UTC
Hi

Sorry but You make confusion. The displayed number is *not* a page number but the serial number in page order: it reflects the choice made in Format> Page> Sheet tab, Page Order: Top to bottom, Then Left to right or right, Then down.

With the attached exemple you get either:

Page1   Page3
Page2   Page4

either:

Page1   Page2
Page3   Page4

In addition, the page number is based on the setting "First page number" in the same tab. So we can have sheets with "Page style" numbering the sheets from one and others from any value. Select them should in no case renumber as you propose.

It is not a bug as Sophie wrote. You can possibly open another Issue (an enhancement request) to be added to the visualization of the page number when in page break preview.

Regards
Pierre-Yves
Comment 9 pierre-yves samyn 2015-05-24 13:53:03 UTC
Created attachment 115968 [details]
PageBreak.ods example