Bug 76347 - [UI] the popup of drawing toolbox icon won't go upside but going down
Summary: [UI] the popup of drawing toolbox icon won't go upside but going down
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-19 09:07 UTC by kr1st0
Modified: 2014-06-11 22:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
showing the error of drawing toolbar icon (65.41 KB, image/png)
2014-03-19 09:07 UTC, kr1st0
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kr1st0 2014-03-19 09:07:49 UTC
Created attachment 96029 [details]
showing the error of drawing toolbar icon

The icon in the drawing toolbar is not normally behave. The pop-up is going down when clicked. The writer must be resize for access the tool/icon.
Comment 1 Thomas van der Meulen 2014-03-21 12:53:29 UTC
Thank you for your bug report, 

I cannot reproduce this on 
Version: 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13
OS: Mac osx 10.9.2

The pop=up opens up for me.
Comment 2 A (Andy) 2014-03-21 21:06:32 UTC
for me not reproducible with LO 4.2.2.1 (Win 8.1)

Maybe it is a Linux issue only?  Can anybody else with Linux test it?
Comment 3 Yousuf Philips (jay) (retired) 2014-06-10 04:04:55 UTC
Dear Kr1stO,

I'm unable to reproduce this either with 4.2.4 on Linux Mint. Can you let us know which linux distribution your using and can you test this issue on 4.2.4 to see if your issue hasnt already been fixed.
Comment 4 kr1st0 2014-06-10 07:50:53 UTC
I'm using Fedora 20 KDE Spin version.


On Tue, Jun 10, 2014 at 11:04 AM, <bugzilla-daemon@freedesktop.org> wrote:

>  Jay Philips <philipz85@hotmail.com> changed bug 76347
> <https://bugs.freedesktop.org/show_bug.cgi?id=76347>
>  What Removed Added  Status UNCONFIRMED NEEDINFO  CC
> philipz85@hotmail.com  Ever confirmed   1
>
>  *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=76347#c3> on
> bug 76347 <https://bugs.freedesktop.org/show_bug.cgi?id=76347> from Jay
> Philips <philipz85@hotmail.com> *
>
> Dear Kr1stO,
>
> I'm unable to reproduce this either with 4.2.4 on Linux Mint. Can you let us
> know which linux distribution your using and can you test this issue on 4.2.4
> to see if your issue hasnt already been fixed.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 5 Robert Großkopf 2014-06-11 04:43:32 UTC
Tested with OpenSUSE 12.3 64bit rpm, KDE 4.10.4 and LO 4.2.2.1. The popup goes up, when the Writer-window is at the bottom of the screen. If there is enough place between the bottom of the Writer-window and the controlbar of KDE it would show the popup downside.

It's working so also in other versions of LO. So I can't confirm this bug.
Comment 6 kr1st0 2014-06-11 06:51:52 UTC
(In reply to comment #5)
> Tested with OpenSUSE 12.3 64bit rpm, KDE 4.10.4 and LO 4.2.2.1. The popup
> goes up, when the Writer-window is at the bottom of the screen. If there is
> enough place between the bottom of the Writer-window and the controlbar of
> KDE it would show the popup downside.
> 
> It's working so also in other versions of LO. So I can't confirm this bug.

Yes, you are right...
Comment 7 kr1st0 2014-06-11 06:53:33 UTC
Have a solution from robert@familiegrosskopf.de:
The popup goes up, when the Writer-window is at the bottom of the screen. If there is enough place between the bottom of the Writer-window and the controlbar of KDE it would show the popup downside.
Comment 8 dE 2014-06-11 16:31:03 UTC
The KDE port of LO is not build against QT, but uses GTK.

So this looks like a GTK bug which's resolution and position specific.

I can confirm this GTK bug in various places from Firefox to XFCE. It happens occasionally for pop up menus. GTK takes wrong decisions on the location where to draw the menu. Never seen this problem in QT apps.

I suggest this be investigated and reported to the GTK team.
Comment 9 Yousuf Philips (jay) (retired) 2014-06-11 22:03:30 UTC
As you confirmed its a GTK issue, then i'm setting it to notourbug.