Bug Hunting Session
Bug 76362 - FORMATTING: Unify separate Legend positioning options
Summary: FORMATTING: Unify separate Legend positioning options
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Chart-Legends
  Show dependency treegraph
 
Reported: 2014-03-19 14:51 UTC by Michael Büker
Modified: 2018-06-27 08:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Büker 2014-03-19 14:51:35 UTC
The "Format Legend" dialog has a tab called "Position", which gives the options "Top", "Left" etc.

However, right-clicking on the Legend also offers (as the second option in the context menu) the "Position and Size" dialog, which offers the general positioning options, but no the "Top", "Left" etc. options from the "Format Legend" dialog.

Users probably do not expect to have both these options, so they should be unified, or at least both dialogs should offer the same options.

Reproduce:
1. Create any chart with a Legend.
2. Right-click the legend.
3. Find "Position and Size" as well as the "Position" tab in the "Format Legend" window.
Operating System: All
Version: 4.1.5.3 release
Comment 1 A (Andy) 2014-03-19 23:08:37 UTC
reproducible with LO 4.2.1.1 (Win 8.1)
Comment 2 Björn Michaelsen 2014-03-20 15:21:02 UTC
Moving from component Chart to ux-advise for our ux guys to have look ;)
Comment 3 sophie 2014-04-02 14:19:56 UTC
Set as New and enhancement - Sophie
Comment 4 Robinson Tryon (qubit) 2016-08-25 05:39:27 UTC Comment hidden (obsolete)
Comment 5 Heiko Tietze 2017-10-22 08:23:02 UTC
The property chart:legend-position can have one out of a number of predefined values, or alternatively be given in absolute coordinates. The Position/Size dialog is just a convenience function for these coordinates making it relative.

The use case for absolute coordinates is not clear to me since entering exact values is only required when the legend should be placed on a fix position inside the chart. For simplicity I would keep the current behavior. 

Other opinions?
Comment 6 Heiko Tietze 2018-06-27 08:26:38 UTC
(In reply to Heiko Tietze from comment #5)
> For simplicity I would keep the current behavior. 

Admittedly, there is an inconsistency but only a minor. And if we take actions we better rename one of the options to "Placement" or "Absolute position", depending on which one. But I still think it's not worth the effort. Other opinions are still welcome but since none was given I'll close the ticket as WFM.