Bug 76403 - FILEOPEN cannot open xlsx file (file with pivot table, experimental features enabled)
Summary: FILEOPEN cannot open xlsx file (file with pivot table, experimental features ...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
Keywords: regression
Depends on:
Reported: 2014-03-20 14:32 UTC by raal
Modified: 2018-02-26 11:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

test file (17.93 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-03-20 14:32 UTC, raal
registrymodifications.xcu with the issue. (deleted)
2014-05-05 21:11 UTC, m_a_riosv
problematic user profile (deleted)
2014-05-06 06:32 UTC, raal

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2014-03-20 14:32:01 UTC
Created attachment 96105 [details]
test file

LO version:
ID sestavení: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
Portable version

Steps to reproduce:
1. open attached file

Current behavior:
LO freeze

Expected behavior:
open the file
Comment 1 m_a_riosv 2014-03-20 22:29:39 UTC
Hi Raal, thanks for reporting.

Version: Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Version: Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13
Version: Build ID: e1823627f35e4419880769fdd05acddbd0a9c25c
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-03-18_14:25:19
Version: Build ID: 12ae7672f285da1d4c730315e8db23b3396b71cc
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-14_00:18:00

Last working: Win7x64
Version: Build ID: 0b772a163b2536fc55aa3b4de925119e33af769
Comment 2 Andras Timar 2014-05-05 17:05:04 UTC
I also tried to reproduce the bug on Win7x64 with 
Version: Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Version: Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13

... and it worked fine, LibreOffice did not freeze. So I think we need more information.
Comment 3 m_a_riosv 2014-05-05 20:57:32 UTC
I have just tried with:
Version: Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0

it works fine after resetting the user profile.
What I have asked a lot of times to do it.

Please Raal, try it.
Comment 4 m_a_riosv 2014-05-05 21:11:19 UTC
Created attachment 98516 [details]
registrymodifications.xcu with the issue.

Attached registrymodifications.xcu, which I can reproduce the issue with Deleting it and starting again the sample file with the issue is open fine.
Comment 5 raal 2014-05-06 06:31:00 UTC
After deletion of user profile it works fine. LO 4.2.3
Comment 6 raal 2014-05-06 06:32:03 UTC
Created attachment 98540 [details]
problematic user profile
Comment 7 Andras Timar 2014-05-06 06:51:00 UTC
back to NEW
Comment 8 raal 2014-06-24 11:25:44 UTC
The problem is caused by Experimental mode (experimental features). When experimental mode is off, then opening xlsx files with pivot table is without freeze.

registry line:
<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="ExperimentalMode" oor:op="fuse"><value>true</value></prop></item>
Comment 9 raal 2014-10-17 18:30:02 UTC
Correct in LO and
Comment 10 Xisco Faulí 2018-02-26 11:24:58 UTC
The content of attachment 98516 [details] has been deleted
Comment 11 Xisco Faulí 2018-02-26 11:25:11 UTC
The content of attachment 98540 [details] has been deleted