Bug Hunting Session
Bug 76407 - Copy - Paste drawing from Visio to LO resulting rotated text not rendered correctly
Summary: Copy - Paste drawing from Visio to LO resulting rotated text not rendered cor...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsWindows needsVisio
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-20 16:34 UTC by Wim de Haan
Modified: 2016-01-15 11:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
zip file contains visio drawing and writer and draw docs with pasted drawing and png with how drawing should look like (32.54 KB, application/zip)
2014-03-20 16:34 UTC, Wim de Haan
Details
Sample Writer document with Visio VSD drawing inserted or pasted (28.78 KB, application/vnd.oasis.opendocument.text)
2015-08-16 15:59 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wim de Haan 2014-03-20 16:34:08 UTC
Created attachment 96111 [details]
zip file contains visio drawing and writer and draw docs with pasted drawing and png with how drawing should look like

I have a simple visio drawing (see attachment). When pasted (even as visio drawing) it is not rendered correctly in writer nor in draw. Only one rectangle of the drawing is visible. Also when it is exported as pdf the rendering is incorrect. Some investigation revealed that it's the rotated text (the "A1" and "A2" text) in the drawing which causes the problem.
Comment 1 Thomas Hackert 2014-04-18 17:10:32 UTC
Hello Wim, *,
I cannot confirm it with LO Version: 4.1.6.1 Build ID: a59ce81388f477fc89db57f0c27f222f31884eb nor with LO Version: 4.2.4.1 Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515 (both parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel) with Germanophone lang- as well as helppack under Debian Testing i686 ... :( If I mark your drawing in your vsd file, copy it and either enter it in a new Draw or a Writer document, I see no difference (or better say: In 4.1.6.1 the borders around the rotated text vanished, but not the text, as in your odt or odg file) ... ;) Would you be so kind to test it with a newer version of LO than 4.2.2.1, please? Maybe it was fixed in the meantime ... ;)
Sorry for the inconvenience
Thomas.
Comment 2 retired 2014-07-27 11:22:43 UTC
Is this bug still valid / reproducible with the latest LO release?
4.3RC3: http://www.libreoffice.org/download/pre-releases/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 3 Wim de Haan 2014-08-11 08:30:09 UTC
This bug is still there for me in 4.3.0.4 release. I tried resetting the user profile folder, but the bug still remains.

@ thackert@nexgo.de 2014-04-18 17:10:32 UTC (Comment 1): I think I know why your exercise goes well. You opened the Visio vsd file with Draw, which shows a good drawing. The bug appears on Windows when I open the vsd file with the Visio program itself, then select (mark) the drawing in Visio and then paste it in either Draw or Writer. In other words the copy - paste action via system clipboard from Visio program to Libre office fails with rotated text in drawing.
Comment 4 Robinson Tryon (qubit) 2014-12-29 22:14:15 UTC
(In reply to Wim de Haan from comment #3)
> The bug appears on Windows when I open the vsd file
> with the Visio program itself, 

Whiteboard -> needsWindows needsVisio
Comment 5 Winfried Donkers (retired) 2015-04-28 07:52:41 UTC
I cannot reproduce the problem:
-o/s Windows 7-64
-LO 4.4.2.2
-I opened the visio document with Visio 2007
-I selected all and copied to clipboard (Ctrl-C)
-I pasted in Writer with Ctrl-V : no problem, only a bitmap was pasted, so enlarging the image is not possible;
-I pasted in Writer with paste special (Shift-Ctrl-V) and Microsoft visio : no problem, enlarging possible without problem, editing in Visio went fine.
-exporting to PDF: the first image (simply pasted) was clearly a bit map, the second image (pasted as Visio object) looked OK.
Comment 6 Buovjaga 2015-04-28 08:04:54 UTC
Wim: did you use Visio 2007 like Winfried?
Could you try with LibreOffice 4.4?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists with LibO 4.4. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 7 V Stuart Foote 2015-08-16 15:59:03 UTC
Created attachment 117945 [details]
Sample Writer document with Visio VSD drawing inserted or pasted

LibreOffice handling .VSD drawings by libvisio tdf#76407 
Version: 5.0.1.1 (x64)
Build ID: 13f702ca819ea5b9f8605782c852d5bb513b3891
Locale: en-US (en_US)

Attached an example .VSD drawing rendered in LibreOffice as Inserted OLE object, Copy paste from Draw, or Copy paste special from Draw. 

--Working in Writer--
Insert → Object → OLE object, create from VSD File (the OLE “window” proportioned to original VSD, but it can be resized.)

--With test.vsd opened in Draw--
Copy all from Draw.  Then a simple Paste into Writer (result is not a bitmap, rather seems to be editable EMF, by individual elements)

Copy all from Draw. Paste Special into Writer (OLE Visio object it gets truncated to the area of selected elements in Draw, but the OLE “window” can be resized).

So remaining issue might be the clipboard handling of Copy from Visio session. Someone with Visio will need to verify the various paste functions. Otherwise, the libvisio filter seems to be doing correct things.
Comment 8 Fridrich Strba 2016-01-15 11:44:05 UTC
Last comment of someone who tried to reproduce and a general lack of opposition to this view, makes me believed that this bug is fixed.