Bug 76433 - BUGZILLAASSISTANT: Verifying normal operation of the BSA does not result in a 'Bad Gateway' error
Summary: BUGZILLAASSISTANT: Verifying normal operation of the BSA does not result in a...
Status: RESOLVED DUPLICATE of bug 77464
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 76469 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-21 09:35 UTC by Robinson Tryon (qubit)
Modified: 2014-05-09 22:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Word doc that had problems with upload (Hello.world_4.2.0.0.beta2.doc) (9.00 KB, application/msword)
2014-03-21 20:38 UTC, Robinson Tryon (qubit)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robinson Tryon (qubit) 2014-03-21 09:35:47 UTC
Per Rost52's email "BSA does not upload after SUBMIT is clicked."
Operating System: All
Version: 4.3.0.0.alpha0+ Master
Comment 1 Robinson Tryon (qubit) 2014-03-21 09:37:36 UTC
RESULT: Bug is filed in FDO as expected. No error visible.
Comment 2 Robinson Tryon (qubit) 2014-03-21 09:57:45 UTC
I've repeated my test of the BSA (On Ubuntu 12.04.3 + FF 27.0.1), and if I try to attach a file using the BSA, I got the following error:

"It looks like you didn't come from the right page (you have no valid token for the..."

Pressing the Submit button again (after a bit of a pause) results in this error:

"Data not yet loaded. Please press submit again in a few seconds."
Comment 3 Robinson Tryon (qubit) 2014-03-21 09:58:00 UTC
Status: NEW, per Rost52's repro
Comment 4 Christian Lohmaier 2014-03-21 13:58:07 UTC
not reproducible here, see bug #76451 and #76452 - I took a relatively large upload with chromium, and a small png with firefox, but no problem in either case.

Maybe people are too impatient and click submit multiple times before the upload/submit is complete?

If this is still reproducible (and not due some hiccup on fdo's side): Please state the browser that was used, and what kind of file you're trying to upload/what size does it have, etc.

I don't see anything obviously wrong with the setup, and for me it works, so I suspect it is either some FDO problem/short outage or some browser quirk...
Comment 5 Robinson Tryon (qubit) 2014-03-21 20:31:32 UTC
(In reply to comment #4)
> not reproducible here, see bug #76451 and #76452 - I took a relatively large
> upload with chromium, and a small png with firefox, but no problem in either
> case.

I tried again (bug 76469), and was unable to repro when uploading a jpeg.

I'll try once more, re:using the ODT that failed for me the first time.

> 
> Maybe people are too impatient and click submit multiple times before the
> upload/submit is complete?

I've been rather patient with my browser. I have had some slight flakiness with the network, so perhaps the BSA needs to be more resilient to network problems?

> I don't see anything obviously wrong with the setup, and for me it works, so
> I suspect it is either some FDO problem/short outage or some browser quirk...

yes, we've seen intermittent issues with FDO previously. Having bugzilla running on our own VM will hopefully give us more insight into any similar problems in the future.
Comment 6 Robinson Tryon (qubit) 2014-03-21 20:37:59 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > not reproducible here, see bug #76451 and #76452 - I took a relatively large
> > upload with chromium, and a small png with firefox, but no problem in either
> > case.
> 
> I tried again (bug 76469), and was unable to repro when uploading a jpeg.
> 
> I'll try once more, re:using the ODT that failed for me the first time.

I just tried again, and had the same error ("It looks like you didn't come from the right page (you have no valid token for the...") when I tried to upload a .doc file (Hello.world_4.2.0.0.beta2.doc - see attachment).
Comment 7 Robinson Tryon (qubit) 2014-03-21 20:38:53 UTC
Created attachment 96186 [details]
Word doc that had problems with upload (Hello.world_4.2.0.0.beta2.doc)
Comment 8 Christian Lohmaier 2014-04-28 14:30:19 UTC
dupe - the crux is that you need to try to file multiple bugs in more or less short time (and with the same browser) to see the effect

*** This bug has been marked as a duplicate of bug 77464 ***
Comment 9 Robinson Tryon (qubit) 2014-05-09 22:03:34 UTC
*** Bug 76469 has been marked as a duplicate of this bug. ***