Bug Hunting Session
Bug 76625 - UI conditional formatting: no feedback when editing
Summary: UI conditional formatting: no feedback when editing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2014-03-26 09:43 UTC by Maarten Brouwers
Modified: 2017-05-22 13:59 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten Brouwers 2014-03-26 09:43:48 UTC
Problem description: 

There is no feedback when you are editing the condition for a conditional format to appear. For example equal to 'A' doesn't work (it should be equal to "A")

Steps to reproduce:
1. Create document
2. Type "A" in first cell (without the quotes)
3. Format -> Conditional Format -> Condition ...
4. Choose [Cell value] [is equal to] [A]
5. Apply style [Header style]

Current behavior:
No warning whatsoever that this is not going to work, similarly, 'A' is also not leading to any warnings


Expected behavior:
When you type in a cell =FIND('A';A1) in B2 (instead of the correct =FIND("B";A1) ) the preview should at least show "#VALUE!" like when a formula contains an incorrect value (I believe that even this warning should be improved (but that would be a different issue))
Comment 1 A (Andy) 2014-03-28 21:30:37 UTC
reproducible with LO 4.2.2.1 (Win 8.1), I would agree that a warning dialog would be better
Comment 2 Maarten Brouwers 2017-05-22 13:59:01 UTC
Marked as RESOLVED-WORKSFORME

The dialog now reports "Strings without quotes are interpreted as column/row labels"

5.1.4.2 on macOS 10.12.4