Bug 76657 - compatibility problem: paste copied cells from LO to AOO
Summary: compatibility problem: paste copied cells from LO to AOO
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clipboard
  Show dependency treegraph
 
Reported: 2014-03-26 20:45 UTC by bugfinderx
Modified: 2020-06-15 19:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugfinderx 2014-03-26 20:45:38 UTC
I found a compatibility bug between AOO 4.0.1 calc and LibreOffice 4.2.2.1 calc (portable-apps-version)

Test System: Windows Vista 32-bit

i copied some cells with simple data from Libreoffice and paste them into AOO.

In AOO the data is not filled regular into the cells, the copied range of cells is inserted as an element.

The reverse way (copy from AOO, paste into LO) works normal.



reproduce:

Open LO calc, fill some cell with number.

select the cells with the mouse and copies this cells (Ctrl+c)

Open AOO calc, paste the cell into the sheet (Ctrl+c)
Comment 1 Dominique Boutry 2014-03-27 11:05:45 UTC
Confirmed with same LibO 4.2.2.1 version and AOO 4.0.0, on Win7 : inserted as a OLE object. The ability to copy into AOO cells is provided by Paste special/DIF : not trivial.

Similar questionnable behaviour when copying from LibO Calc to LibO Writer : also defaulted to OLE object, I found no way to get a table.

Kept to UNCONFIRMED to get additionnal advices.
Comment 2 raal 2014-11-23 21:35:06 UTC
I can confirm with LO 4.3.4 and AOO 4.1.1,win7
Comment 3 QA Administrators 2015-12-20 16:17:08 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-01-03 19:49:41 UTC Comment hidden (obsolete)
Comment 5 Timur 2020-06-15 19:25:05 UTC
I don't see why this was confirmed. This looks like NotOurBug and AOO should resolve it.