Bug Hunting Session
Bug 76669 - Improve usability of character set combo/dropdown list in CSV Export options window (and possibly other places)
Summary: Improve usability of character set combo/dropdown list in CSV Export options ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-27 02:00 UTC by mariush
Modified: 2017-02-02 21:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mariush 2014-03-27 02:00:37 UTC
In LibreOffice Calc, when saving a spreadsheet as a csv file, LibreOffice pops a window showing export options such as choosing character set, delimiter, character used for wrapping texts and other things. 
The character set drop down combo (whatever it's called) is needlessly small, it only shows 5 entries at a time so if I want for example to select UTF-8, it's a frustrating experience. 

In other windows, for example Text Import when opening a CSV file, the drop down list fully expands.

In my opinion, the list in the export window should expand more as long as there's room on the screen, just like it expands fully in the "text import" window.

PS. I actually paused from writing this because I noticed I had version 4.1 and now I installed 4.2.2.1 (straight from main page) and the same problem exists but instead of 4 entries, now there are 5 entries shown. Also, now it's actually quite better because the character sets seem to be sorted, not just listed in a somewhat random way. In previous version I had to go down one by one to get UTF-8 in view to select it. Now at least I can go fast to U and then select UTF-8.
Comment 1 A (Andy) 2014-03-28 21:21:53 UTC
I would agree, in the Import Dialog this is better resolved with more entries shown at a time.

reproducible with LO 4.2.2.1 (Win 8.1)
Comment 2 gekacheka 2017-02-02 21:57:11 UTC
Works for me, the save as csv, Export Text File dialog, Character Set drop down menu shows a scrolling window of 25 character sets sorted by name. 
 
LibreOffice 5.2.3.3 on MSWin7, English.