Bug 76863 - LibreOffice Draw doesn't start
Summary: LibreOffice Draw doesn't start
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-31 21:50 UTC by bdjnks
Modified: 2014-04-16 12:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Systemd Journal data for the crashes. (1.27 KB, text/plain)
2014-03-31 21:50 UTC, bdjnks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bdjnks 2014-03-31 21:50:35 UTC
Created attachment 96686 [details]
Systemd Journal data for the crashes.

Problem description: 

Running Libreoffice Draw, by any method, shows only the splash screen. Before the program loads further, it simply segfaults.

Steps to reproduce:
1. Run 'libreoffice --draw'

Current behavior:

crashes

See the attached logs.

Expected behavior: 

shouldn't crash...
Operating System: Linux (Other)
Version: 4.2.2.1 release
Comment 1 bdjnks 2014-04-02 03:43:28 UTC
Although I still believe this to be a libreoffice bug, I've managed to resolve it for myself. Here are the steps I took:

1. Install the libreoffice-kde4 package (or it's equivalent for your systems), including any dependencies, while re-installing the rest of libreoffice.
2. Remove the libreoffice-kde4 package.

This process worked on archlinux and the issue is resolved for me, though I don't know why.
Comment 2 Dominique Boutry 2014-04-08 15:34:00 UTC
I can't manage to reproduce on LibO 4.2.2.1 on Win7.
Comment 3 tommy27 2014-04-13 19:37:24 UTC
@bdjnks
not reproducible with 4.2.3.3 under Win7x64
try upgrading to latest version and tell us if you still see this bug.
Comment 4 Maxim Monastirsky 2014-04-16 12:52:39 UTC
(In reply to comment #1)
> 1. Install the libreoffice-kde4 package (or it's equivalent for your
> systems), including any dependencies, while re-installing the rest of
> libreoffice.
> 2. Remove the libreoffice-kde4 package.
> 
> This process worked on archlinux and the issue is resolved for me,
IMHO it's clearly a packaging issue, so closing as NotOurBug.