Download it now!
Bug 76872 - Connector lines should arc/hop over other perpendicular (unrelated) connectors
Summary: Connector lines should arc/hop over other perpendicular (unrelated) connectors
Status: RESOLVED DUPLICATE of bug 54990
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Connectors
  Show dependency treegraph
 
Reported: 2014-03-31 23:33 UTC by zaxebo zaxebo
Modified: 2016-06-20 12:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
visual description for the arc (1.22 KB, image/png)
2014-03-31 23:33 UTC, zaxebo zaxebo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zaxebo zaxebo 2014-03-31 23:33:38 UTC
Created attachment 96689 [details]
visual description for the arc

When two connectors cross (as perpendicular lines), they currently simply cross 
at a right angle. It would be very useful to have (as an option, perhaps?) the 
ability to make one connector hop over the other in the form of a short arc or little curve. 
Microsoft Visio and several CAD programs support this behavior which is 
commonly used in electrical diagrams of all sorts. See the attachment for an 
example of what I mean if it's not clear. Thank you for a fine product.

( for reference: please the prior bug filings in "openoffice" and user demand for this:
https://issues.apache.org/ooo/show_bug.cgi?id=50971
https://issues.apache.org/ooo/show_bug.cgi?id=81290
https://forum.openoffice.org/en/forum/viewtopic.php?f=11&t=19667
)

This is just a restatement of a long standing request from users
Comment 1 Alex Thurgood 2015-02-01 11:39:38 UTC
Seems valid request for enhancement.
No idea how complicated it would be to develop such a feature though.
Comment 2 Heiko Tietze 2016-04-29 13:26:43 UTC
This was a frequently requested feature in the Draw survey [1]. Arc'ed intersection is one known solution, the other is to intersect and indicate that by dimension lines, or the like.

[1] https://design.blog.documentfoundation.org/2016/04/01/the-many-faced-god-part-2-how-libreoffice-draw-is-expected-to-evolve/

(Setting the priority to high because of the number of requests)
Comment 3 Heiko Tietze 2016-06-20 12:52:42 UTC

*** This bug has been marked as a duplicate of bug 54990 ***