Bug Hunting Session
Bug 76901 - In Standard Filter dialog, remove the "None" option from "Field Name"
Summary: In Standard Filter dialog, remove the "None" option from "Field Name"
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-01 12:22 UTC by narayanaras
Modified: 2015-08-01 19:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2014-04-01 12:22:57 UTC
Take any dataset and apply Autofilter to it. (Data > Filter > Autofilter).
Then click on any column head, and select "Standard Filter" option.

The Standard Filter GUI pops up.

Click on the first pull-down ("Field Name"). 
Observe that it lists a "-None-" option.

In terms of query-building, this creates confusing statements:

Let us try a few sample statements:
1. Find None that is empty
2. Find None that is not empty

Also, the GUI behaves erratically:
1. When we choose an option from a pull-down list, the options available in the pull-down on its right should be altered suitably. But in some cases it is reverse: When you select something on the right, the left column options change (which you had already selected!).

2. Some of the pull-down menus are grayed out, but the behavior is neither consistent nor logical.

See the video here:
https://drive.google.com/file/d/0BwlATzWr1zTOQTNIQV9SZ25UcEE/edit?usp=sharing

Please download and inform so that I can remove the video from my drive.
I do not intend to keep it indefinitely.

Desired:
1. Remove the "None" option.
2. Introduce the "left-to-right" behavior
   (when we operate a control, all the controls on its right side, or below, MAY change their behavior. But it must NEVER happen in the reverse direction.)
Comment 1 narayanaras 2014-04-01 12:25:52 UTC
p.s. The GUI seems to have some influence of the past status (what was selected a few steps ago). As if following an elaborate state chart.

But most of the behavior is not logical, so I conclude that it is an accidental case (not the intended behavior).
Comment 2 A (Andy) 2014-10-01 21:19:37 UTC
For me it is currently also not clear for what you need / would use "none".  I can also not find anything in the LO help.  Maybe somebody else can help?
Comment 3 raal 2015-02-10 18:57:59 UTC
(In reply to A (Andy) from comment #2)
> For me it is currently also not clear for what you need / would use "none". 
> I can also not find anything in the LO help.  Maybe somebody else can help?

http://openoffice.blogs.com/openoffice/2008/05/copying-only-th.html
Comment 4 Jean-Baptiste Faure 2015-08-01 19:51:50 UTC
"None" option is also an easy mean to undo the filtering.

According to comment #3 closing as WontFix.

Best regards. JBF