Bug 76911 - EDITING: Load htm-file, crash
Summary: EDITING: Load htm-file, crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-01 16:26 UTC by berthu
Modified: 2014-08-30 13:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
simple htm file, LOW its have enlarged for file descriptions (119.79 KB, text/html)
2014-04-01 16:26 UTC, berthu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description berthu 2014-04-01 16:26:45 UTC
Created attachment 96736 [details]
simple htm file, LOW its have enlarged for file descriptions

Problem description: 

Steps to reproduce:
1. load file allegated....
2. first file edited, imagelink, image enlarget....
3. file recover dit Ok, crashs....

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.2.2.1 release
Comment 1 Jorendc 2014-04-07 21:19:33 UTC
Failed to reproduce a crash, tested using Linux Mint 16 x64 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: d06cc9b52d3023f7b5aacb50bd48b06b9ffefbd3

Kind regards,
Joren
Comment 2 John Smith 2014-04-14 17:17:23 UTC
when opening this html file with with 4.2.2.1, libreoffice hangs/freezes
Comment 3 Caolán McNamara 2014-08-28 10:42:51 UTC
Since bug #50763 was fixed the base64 image is parsed and shown as an image, but in 4.2 the string limits are stll 64k for the html parser so not all the data makes it into the image and the overflow is random text.

The real fix for this is

commit e576b083c88b97750ce261da80c3933cc04725a7
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Tue Jan 14 09:50:47 2014 +0000
longparas: drop STRING_MAXLEN use now

and so everything is properly fixed in 4.3. It looks like junk in 4.2.6.2 but doesn't hang for me anymore
Comment 4 berthu 2014-08-28 10:51:00 UTC
Thanks
Engelbert

Gesendet von meinem BlackBerry 10-Smartphone.
Von: bugzilla-daemon@freedesktop.org
Gesendet: Donnerstag, 28. August 2014 12:42
An: berthu@live.at
Betreff: [Bug 76911] EDITING: Load htm-file, crash


https://bugs.freedesktop.org/show_bug.cgi?id=76911

Caolán McNamara <caolanm@redhat.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|---                         |FIXED
           Assignee|libreoffice-bugs@lists.free |caolanm@redhat.com
                   |desktop.org                 |

--- Comment #3 from Caolán McNamara <caolanm@redhat.com> ---
Since bug #50763 was fixed the base64 image is parsed and shown as an image,
but in 4.2 the string limits are stll 64k for the html parser so not all the
data makes it into the image and the overflow is random text.

The real fix for this is

commit e576b083c88b97750ce261da80c3933cc04725a7
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Tue Jan 14 09:50:47 2014 +0000
longparas: drop STRING_MAXLEN use now

and so everything is properly fixed in 4.3. It looks like junk in 4.2.6.2 but
doesn't hang for me anymore

--
You are receiving this mail because:
You reported the bug.
Comment 5 berthu 2014-08-30 13:10:37 UTC
Dear Mister Caolán McNamara,

in Deutsch:

hatte meine Website mit OpenOffice, bis dann mit LibreOffice herauskam, 
erstellt.

Wenn ich nun einzelne Pages lade, bearbeite-speichere, so wird das 
Layout zerstört.
Die Website ist so nicht editierbar. (altes Thema)

Wenn Ihr unter html  speichert, wird das Resultat auch verifiziert?

Bin kein Webdesigner, und somit nicht informiert mit welch ähnlichem 
Tool ich meine Website erstellen sollte.
War mit dem Resultat eigentlich zufrieden, (man bot mir mehrmals an, es 
zu verbessern) weil ich keinen
Schnick-Schnack und allerhand Log-Spionage will.

Wenn ich LO "nicht" dafür verwenden kann, möchte ich es nur wissen. 
Vielleicht ist es aber auch nur ein Flüchtigkeitsfehler.
Die Hilfe zu den Frameeinstellungen, Bilder einfügen, ist nicht gerade 
intuitiv, verständlich

Vielen Dank und Grüße

Engelbert Huber
www.elektrik-systeme.com  (als Kontroll-Objekt)



Am 28.08.2014 um 12:42 schrieb bugzilla-daemon@freedesktop.org:
> Caolán McNamara <mailto:caolanm@redhat.com> changed bug 76911 
> <https://bugs.freedesktop.org/show_bug.cgi?id=76911>
> What 	Removed 	Added
> Status 	NEW 	RESOLVED
> Resolution 	--- 	FIXED
> Assignee 	libreoffice-bugs@lists.freedesktop.org 	caolanm@redhat.com
>
> *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=76911#c3> 
> on bug 76911 <https://bugs.freedesktop.org/show_bug.cgi?id=76911> from 
> Caolán McNamara <mailto:caolanm@redhat.com> *
> Sincebug #50763  <show_bug.cgi?id=50763>  was fixed the base64 image is parsed and shown as an image,
> but in 4.2 the string limits are stll 64k for the html parser so not all the
> data makes it into the image and the overflow is random text.
>
> The real fix for this is
>
> commit e576b083c88b97750ce261da80c3933cc04725a7
> Author: Caolán McNamara <caolanm@redhat.com  <mailto:caolanm@redhat.com>>
> Date:   Tue Jan 14 09:50:47 2014 +0000
> longparas: drop STRING_MAXLEN use now
>
> and so everything is properly fixed in 4.3. It looks like junk in 4.2.6.2 but
> doesn't hang for me anymore
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>