Download it now!
Bug 76923 - stripes instead of the correct rendering of transparency gradients
Summary: stripes instead of the correct rendering of transparency gradients
Status: RESOLVED DUPLICATE of bug 81148
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-04-01 20:42 UTC by László Németh
Modified: 2015-12-15 11:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bad rendering of transparency gradient (12.05 KB, image/png)
2014-04-01 20:45 UTC, László Németh
Details
test file (14.29 KB, application/vnd.oasis.opendocument.graphics)
2014-04-01 20:46 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description László Németh 2014-04-01 20:42:44 UTC
I have found it in the 2-month old master, see the attached screenshot and test file.
Comment 1 László Németh 2014-04-01 20:45:11 UTC
Created attachment 96748 [details]
bad rendering of transparency gradient

left: LibreOffice 4.3.0.0.alpha0+, right: LibreOffice 4.2.2.1
Comment 2 László Németh 2014-04-01 20:46:30 UTC
Created attachment 96749 [details]
test file
Comment 3 Andras Timar 2014-04-02 13:06:25 UTC
a5351434fbea1126961f5dbaa986e7c9e686c24e is the first bad commit
commit a5351434fbea1126961f5dbaa986e7c9e686c24e
Author: tsahi glik <tsahi.glik@cloudon.com>
Date:   Thu Jan 16 12:51:44 2014 -0800

    fix rendering issues in iOS with aqua
Comment 4 Cor Nouws 2014-06-22 19:12:00 UTC
I confirm this
Comment 5 Milos Sramek 2014-07-07 12:15:35 UTC
Hi,
I confirm this also in Impress. It seems that the bug is related only to objects created by older versions of LO. If a gradient is created in 4.3, it is OK
milos

Bibisection results:
77962b3d9a08d8c7177b2c67da6ed1c5bc26572c is the first bad commit
commit 77962b3d9a08d8c7177b2c67da6ed1c5bc26572c
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sun May 11 02:41:01 2014 +0000

    source-hash-d1ba55a28cd40134356faf3e01971491086591d9
    
    commit d1ba55a28cd40134356faf3e01971491086591d9
    Author:     Tor Lillqvist <tml@collabora.com>
    AuthorDate: Wed Jan 15 08:50:40 2014 +0200
    Commit:     Tor Lillqvist <tml@collabora.com>
    CommitDate: Fri Jan 17 00:17:02 2014 +0200
    
        Indentation fix
    
        Change-Id: Iab16c4ff664f9bcc53458e5f7c249d3fb030fe07

:100644 100644 078d4fe451f07f1d344efdf613645d01e477cad9 aa258d9750727f895664155ea964f57acdaa2980 M	ccache.log
:100644 100644 a60d1828ec08b802f939c6ab9ced8d795a09f8ba f836dd408e23f644cabc40670b0305adde596698 M	commitmsg
:100644 100644 8e5a1ba748a7ca66a673cdbc5ca39f024406a1e8 ad01f546ed041b63ff47a332a3768817f44a68d8 M	make.log
:040000 040000 ed375e6fe30120b84a779265ef85d1f35bab1852 0604908e57bd561936d20fb38f270d6490ac89ee M	opt

milos@trigan:/media/milos/Samsung1TB-Ext4/milos/LO/bibisect-43all$ git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# bad: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect bad a900e72b6357882284c5955bdf939bf14269f5fb
# bad: [e1d0365cd2b073a859f59ad0a4584385a66dc611] source-hash-2eea96c702a44ab009743b0d22ef639127f0b57b
git bisect bad e1d0365cd2b073a859f59ad0a4584385a66dc611
# bad: [98a55bf95f3ec29298751fd8fba76dd2236dce43] source-hash-58dfc97ca697875c36b7ddf14f5505a93d7b9cf8
git bisect bad 98a55bf95f3ec29298751fd8fba76dd2236dce43
# bad: [92ca7e7dd4470107453ce3e99f3675387f91bf24] source-hash-ed5065d8b080bfaf51ea1232cebf3ff72af1e640
git bisect bad 92ca7e7dd4470107453ce3e99f3675387f91bf24
# good: [6b545103ded12a7a1e7b490734eb094344a0f3ca] source-hash-76702bc75d79dee09a01c57c68e49efa5664c355
git bisect good 6b545103ded12a7a1e7b490734eb094344a0f3ca
# good: [5023c3e436e8a445b700a81bd4a404673084678a] source-hash-5da974369d01760b336de34e68c03d7268d2d330
git bisect good 5023c3e436e8a445b700a81bd4a404673084678a
# bad: [77962b3d9a08d8c7177b2c67da6ed1c5bc26572c] source-hash-d1ba55a28cd40134356faf3e01971491086591d9
git bisect bad 77962b3d9a08d8c7177b2c67da6ed1c5bc26572c
# good: [f1e56b0f09e0a75b8970a8b9892298f0ca210200] source-hash-eeeefd6fd87b3cff18ba9078869bdfcd0e351d6f
git bisect good f1e56b0f09e0a75b8970a8b9892298f0ca210200
# first bad commit: [77962b3d9a08d8c7177b2c67da6ed1c5bc26572c] source-hash-d1ba55a28cd40134356faf3e01971491086591d9
Comment 6 László Németh 2014-07-15 12:48:48 UTC

*** This bug has been marked as a duplicate of bug 81148 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:03:43 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]