Download it now!
Bug 76994 - Add an animate effect to move an element along a curve/arrow
Summary: Add an animate effect to move an element along a curve/arrow
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-03 11:47 UTC by narayanaras
Modified: 2017-01-30 16:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2014-04-03 11:47:28 UTC
Often we need to show a collage of shapes/images, and then move some of its parts to a new position, to create a new shape. 

Almost like how a car gets transformed into Optimus Prime! ;)

Psychologically, when such transformation happens right before your eyes, it is convincing that just by re-arranging parts of a car, you can actually create that robot.

In real world, such demonstration has practical uses.
Here are two typical use cases:

1. I want to suggest a change in a GUI by re-arranging some of its parts.
   (e.g. Bug#76937)

2. I want to show how a process can be re-engineered.

As a change agent, I must reassure my audience that the new proposal is not radically different.

But when I show the "before" and "after" pictures in different slides, my audience may not get that comfort. The transition is too abrupt.

So if I can gradually morph the initial image into final image piece by piece, the audience would readily grasp that the new situation is just a rehash of old elements (with only a few new elements).

To create this effect, I may have to cut up the GUI into individual parts beforehand, and re-assemble them to look like the original GUI. In case of a flowchart, I can simply move the individual boxes.

DESIRED FEATURE:
---------------

Please provide a facility so that we can move the position of any object along a curve/line/polyline.

(This is a special case of "fly in" animation, but instead of the object coming in from outside the canvas, the movement would be within the canvas.)

This kind of animation is not yet provided in Impress.

IMPLEMENTATION NOTES:
--------------------

The vector used as path of the movement can be hidden by various methods:
1. increasing its transparency 
2. using a visibility control (new feature)
3. Making it same color as background
4. Insert a blank "canvas" object, and push the path below this canvas.
5. Defining a new type of object that is not rendered in slideshow mode.
Comment 1 Joel Madero 2014-05-19 15:28:19 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date:   Thu Apr 24 21:43:16 2014 +0300
Platform: Ubuntu Linux 14.04 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Low - while nifty as a new enhancement, not going to dramatically improve most users day to day use of the product.

Note: All enhancements (and all bugs) are chosen by volunteers so there is no guarantee when an enhancement will be fixed. I am confirming that it is a valid request.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Regina Henschel 2017-01-30 16:25:41 UTC
The feature is already implemented since OpenOffice.org 1.0. Currently you find it in the collection of animations in the category "Motion Paths". You can easily change the paths and adapt them to your needs in the point editor.

Therefore I set it to WORKSFORME

I have used Version: 5.4.0.0.alpha0+
Build ID: 5903235d57acb13d9d5286d23b443a01aeab9a3c
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-19_00:12:28
Locale: de-DE (de_DE); Calc: group