Download it now!
Bug 77248 (hogging) - 500 page document hogging CPU and crashes randomly
Summary: 500 page document hogging CPU and crashes randomly
Status: RESOLVED WORKSFORME
Alias: hogging
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-09 18:07 UTC by alexander.jansen
Modified: 2017-05-31 07:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The document that keeps crashing (193.78 KB, application/vnd.oasis.opendocument.text)
2014-04-09 18:07 UTC, alexander.jansen
Details
Assertion failure (developers) (19.88 KB, image/png)
2014-06-04 15:05 UTC, Florian Reisinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alexander.jansen 2014-04-09 18:07:31 UTC
Created attachment 97150 [details]
The document that keeps crashing

I have a 500 page document with phrases in various languages and fonts to see how fonts change between languages. Unfortunately it is hogging CPU and crashes randomly. I have the relevant file attached.
Comment 1 Tomaz Vajngerl 2014-04-09 18:35:03 UTC
Doesn't crash for me in 4.2. Maybe 4.1 specific?
Comment 2 Adolfo Jayme 2014-04-10 23:34:19 UTC
... neither does the attachment crash for me. Can you try a newer LibreOffice version?
Comment 3 alexander.jansen 2014-04-11 11:38:07 UTC
I usually just use the current version from my package manager, but my system is generally a bit unstable at the moment. Those facts may be related…
Comment 4 John Smith 2014-04-14 17:01:17 UTC
i cannot reproduce the crash with the document in the attachment with 4.2.2.1.
Comment 5 alexander.jansen 2014-04-14 19:01:28 UTC
When working on this document while running LibreOffice through terminal, I get the following error: “warning: line 190: incompatible stripping characters and condition” with a couple of different lines.
Comment 6 tommy27 2014-05-03 23:31:03 UTC
edited summary notes.
Comment 7 retired 2014-05-04 09:55:56 UTC
Is this bug still valid / reproducible with the latest LO release?  Currently 4.2.3: http://www.libreoffice.org/download/libreoffice-fresh/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Since so far no one with 4.2.x has been able to reproduce chances are good this is fixed in LO 4.2.

Setting to NEEDINFO until more detail is provided.
Comment 8 alexander.jansen 2014-05-04 21:16:18 UTC
Still crashes after upgrade. Might be a system related problem with the kernel or depending libraries in my system, as I regularly update system software. It is not a particularly important document anyway.
Comment 9 tommy27 2014-05-05 06:35:21 UTC
@alexander
do not change version field that way.
it has always to indicate the 1st version you saw the bug, not the latest.
Comment 10 Florian Reisinger 2014-06-04 15:05:44 UTC
Created attachment 100400 [details]
Assertion failure (developers)

Reproduceable with 4.4alpha1
Version: 4.4.0.0.alpha0+
Build ID: c0190efe9e2e27bd60fbf7e35a698e1e3c4ef77c
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-02_07:51:43
Comment 11 Florian Reisinger 2014-06-04 15:10:52 UTC
Working with: LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
and Version: 4.1.5.3
Build-ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24
and Version: 4.2.1.1
Build-ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

Thus changing version to current master (as stated out)
I am on Win 7 x64
Comment 12 tommy27 2014-10-17 04:29:40 UTC
no crash under Win7x64 using LibO 4.3.2.2 and  4.4.0.0.alpha0+
Build ID: 2d6dacc1c93bfd4a9086f8fde6b0edbfdeb573c9
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-13_23:44:09

I set status to WORKSFORME, feel free to revert if you still see the issue
Comment 13 Jean-Baptiste Faure 2014-10-17 04:48:59 UTC
I get a crash with version 4.4.0.0.alpha+ just updated and built at home under Ubuntu 14.04 x86-64. To reproduce:
1/ open the document (fine, no problem)
2/ scroll to the end and come back at the beginning.
3/ open the Navigator and double-click on some header
=> crash.

Almost same crash with versions 4.2.6 and 4.3.4.0.0+ but there I need to scroll forth and back and double-click on headers in the Navigator several times before to get a crash.

Note: I do not click inside the document when scrolling.

Do you reproduce the crash using this scenario ?

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 14 QA Administrators 2015-05-06 14:14:18 UTC Comment hidden (obsolete)
Comment 15 David 2015-05-08 10:02:28 UTC
I have confirmed this bug as described in comment 13 on Linux with a newly compiled version 5.0.0.0.alpha1 ID efdd215124df0ab98a33525ac01a9d8ff4a542d4.  It did not crash immediately, but after scrolling back & forth a bit and selecting various headings and continuing to scroll, it crashed after about maybe a minute.  I am having what looks to be like the same issue as this with another file.  The crashes seem to have become quite a bit more frequent after the following commit:

commit e8b97a52c96df9c8e8055407b1e40ed7cb9cfc67
Merge: 2b0be6c 0cde74f
Author: Michael Meeks <michael.meeks@collabora.com>
Date:   Tue Apr 28 11:41:31 2015 +0100

    Merge remote-tracking branch 'origin/feature/vclptr'
    
    Resolve several thousand lines of conflicts.
Comment 16 Michael Meeks 2015-05-15 09:34:01 UTC
This is very unlikely to be VclPtr related; the assertion is:

vcl/.../winlayout.cxx:1291

mnSubStringMin <= rVisualItem.mnEndCharPos

which looks like a purely font related issue. Hard to say who is best with fonts - but I suspect Caolan would know =)
Comment 17 QA Administrators 2016-09-17 03:49:22 UTC
Version: 5.3.0.0.alpha0+
Build ID: d9cff00683d31fbd4b3c4c2d6afbe164f4a85d47
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

I get a crash just scrolling down - no additional steps needed. My scroll gets way ahead of the GUI so I let go of Pg Dn after about 30 seconds of holding it, screen keeps scrolling, eventually crashes
Comment 18 Telesto 2017-05-30 09:23:05 UTC
I can't reproduce it on Windows with
Versie: 5.4.0.0.beta1 
Build ID: 8672113ead4e403c55e31b1d9a3d1e0f3b299577
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

I tested it as described in comment 13 and comment 17
Comment 19 Jean-Baptiste Faure 2017-05-31 07:18:42 UTC
Not reproducible anymore for too with LibreOffice 5.3.3 (Ubuntu build) and LibreOffice 5.4.0.0.beta1+ built at home under Ubuntu 16.04 x86-64, both with GTK3 engine.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF