Bug Hunting Session
Bug 77261 - Cut / Copy / Paste buttons clutter the standard toolbar while encouraging poor practices
Summary: Cut / Copy / Paste buttons clutter the standard toolbar while encouraging poo...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-10 05:51 UTC by Daniel Hulse
Modified: 2014-04-19 22:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Hulse 2014-04-10 05:51:34 UTC
The Cut, Copy, and Paste buttons should be removed from the standard toolbar for a couple of reasons: 

The first reason is that they take up unnecessary space in the standard. Cut, Copy, and Paste is almost ALWAYS done using either the right-click menu or keyboard shortcuts. So it's unnecessary for them to be in the standard toolbar where they just add clutter. 

The second is that it could cause some confusion for new users, since the user must know exactly where the cursor is in order to paste something there. If a user doesn't know where the cursor is and decides to cut or paste something, they're going to have a bad time because the thing they are trying to paste into the document is going to end up at a seemingly random part of the screen. So the toolbar entries should be removed to prevent this confusion. 

The third is kind of a philosophical reason. The point of the toolbar is to make certain actions quicker (and possibly more accessible). Using the toolbar for cutting and pasting, however, is actually slower than the right-click menu alternative. In addition, the cut, copy, and paste entries are one of the few things that everyone knows are in the right click menu--there's no need to make them any more accessible.
Comment 1 Samuel Mehrbrodt (CIB) 2014-04-10 07:15:52 UTC
I agree completely with Daniel - there is no need for these buttons in the toolbar.
Comment 2 Samuel Mehrbrodt (CIB) 2014-04-10 07:16:57 UTC
Well, actually I sometimes use the "Insert" button in the toolbar since it lets you select _how_ you want to insert something (Unformatted, HTML, etc.)
Comment 3 Heiko Tietze 2014-04-10 08:48:02 UTC
Good usability does not start with "I do not use" or "I dislike" (even if I agree with the philosophical consideration). According to user data [1] at least the copy function is used regularly. Removing all clipboard functions might confuse users because it's a quasi standard. But our results [2] confirm that standard toolbar should get a revision.

[1] https://wiki.openoffice.org/wiki/Tracking_results#Impress_Usage_Data_for_Download
[2] http://user-prompt.com/conclusions-of-the-libreoffice-icon-test/
Comment 4 Jean-Baptiste Faure 2014-04-11 07:46:45 UTC
Hi Daniel,

Are you serious ?

I totally disagree with your three statements:
1/ why punish the users who prefer to use the buttons instead of the right click menu?
2/ I do not see where is the difference between toolbar and right click menu here. How the use of the right click menu make the things better?
3/ "The point of the toolbar is to make certain actions quicker (and possibly more accessible)": from my point-of-view, the main role of a toolbar is to make visible the most important functions of the software, even if you do not search them. To use the right-click menu, you need to know or to hope that the function exists and that you could find it here. When you have a toolbar in front of you with standard icons, you see the function.

If I consider my own practice, I can say that I do differently when I use a mouse and when I use a touchpad. With the mouse, I use the right click menu, and with the touchpad I use the toolbar or the shortcuts because I find the touchpad less precise when selecting a submenu. With the button I am sure to click the right function. You should take that in account.

Best regards. JBF
Comment 5 Tor Lillqvist 2014-04-11 07:48:13 UTC
This discussion is pointless.
Comment 6 Adolfo Jayme 2014-04-11 08:29:57 UTC
> This discussion is pointless.

Indeed. This is one of those cases where it’s better to agree to disagree.

For instance, I can’t think of any good reason why having those buttons there is “a bad practice.” What!?

Sincerely, I’d WONTFIX this.
Comment 7 Tor Lillqvist 2014-04-11 08:37:51 UTC
Adolfo: You misunderstood me. I meant that it is pointless to have a discussion about what will ultimately always be a matter of taste. Any change, no matter how much it makes sense to good designers, will always be opposed by some people as a HORRIBLE REGRESSION!!! See https://xkcd.com/1172/ .
Comment 8 Daniel Hulse 2014-04-11 11:14:34 UTC
Heiko the data in the link you attached is interesting, but I'm not sure it really contradicts what I'm saying. 2.5%, 4.1%, and 0.6% are the percentage of clicks for each, which I'm willing to bet it's a low proportion compared to the the total amount cutting and pasting as a whole. Furthermore, while these functions in the MS Office ribbon, I think it's of note that they aren't in the toolbars of Apple Pages or Google Docs. I agree that the whole of the standard toolbar needs to be reevaluated.

JBF this isn't punishment. If having these entries in the toolbar is critical for your work-flow, you can re-enable them. In addition, your problem with using touchpads would be totally avoided through keyboard shortcuts. "From my point-of-view, the main role of a toolbar is to make visible the most important functions of the software" is a very simplistic take on ux-visual hierarchy. If that's the role of the toolbar, then why don't we let users edit text straight from the toolbar? I'll tell you why: because the page is a much, much more appropriate place to edit text from. The same logic applies to an extent to cutting and pasting.

Cut and Paste functions are given a prominent place in the right-click menu. It's pretty much a universal thing across operating systems that the right-click menu has cut and paste functionality. No user is going to be wondering if the cut or paste buttons are in a right click menu--they're always there. In fact, using right-click menus is central to cutting and pasting everywhere else: File managers, web browsers, image editors, and most other kinds of software keep cut and paste functionality prominently in the right click menu. In addition, it's always in the EDIT menu and has some fairly easy-to-remember keyboard shortcuts. So adding a toolbar entry to make the functionality even more prominent is unnecessary and contrived.  

Note that this change would be in alignment with ux-minimalism.
Comment 9 Adolfo Jayme 2014-04-11 13:17:16 UTC
(In reply to comment #7)
> Adolfo: You misunderstood me.

Let’s see...

> ... I meant that it is pointless to have a
> discussion about what will ultimately always be a matter of taste.

Before that I said:

> This is one of those cases where it’s better to agree to disagree.

So we both said the same thing with different words. Or didn’t I?
Comment 10 Adolfo Jayme 2014-04-11 13:19:57 UTC
(In reply to comment #8)
> Cut and Paste functions are given a prominent place in the right-click menu.
> It's **pretty much**

You said it. It’s not a rule.

I don’t find it wrong to have duplicate commands in different parts of a program’s user interface. In fact, that’s a good thing.
 
> Note that this change would be in alignment with ux-minimalism.

I wouldn’t like LibreOffice becoming another dumbed-down app! Honestly!
Comment 11 Tor Lillqvist 2014-04-11 13:24:54 UTC
I want LibreOffice to become easier to use. If you call that "dumbed down", ok, fine with me. I am dumb.
Comment 12 Adolfo Jayme 2014-04-11 13:27:10 UTC
Pffft… I’m better off
Comment 13 Stefan Knorr (astron) 2014-04-13 13:56:39 UTC
So, I fundamentally agree with the second argument from the description:
   The Cut, Copy, and Paste buttons "could cause some confusion for new
   users, since the user must know exactly where the cursor is in order
   to paste something there"
It happens to me too, occasionally.

I am mostly ambivalent about the first and third reason Daniel gives.

Now, the context menu is indeed not known to everybody. Especially Mac users, used to one-button mouses don't always know that anything like the context menu exists. And given how plenty of people seem to be unable to use a computer beyond some specific instructions they were given during their training, I'd say the context menu is at least not too obvious.

However, Microsoft Office 2010 introduced a floating, half-transparent toolbar widget* that would help us out here:
+ close to the text cursor => precise, quick
+ always visible => obvious
=> it would be possible to remove the toolbar icons

The caveat of this solution is that it requires some grace in displaying the toolbar, maybe even a little animation. LibreOffice does not do well in this area currently. (See the still-jerky animations of the Header/Footer indicator.)
It might also need some fine-tuning (hide if the user hasn't moved the mouse for 5 seconds etc.), to make it unobtrusive.


* If you're on Linux, try Bijiben aka GNOME Notes. It has a formatting
  toolbar that works somewhat similar to the Office toolbars, but only
  appears when text is selected.
Comment 14 Cor Nouws 2014-04-19 12:47:10 UTC
(In reply to comment #13)
> So, I fundamentally agree with the second argument from the description:
>    The Cut, Copy, and Paste buttons "could cause some confusion for new
>    users, since the user must know exactly where the cursor is in order
>    to paste something there"
> It happens to me too, occasionally.


So we can expect proposals too to remove buttons to insert a table, an
autotext, a chart, insert a whatever ?

I would say: WONTFIX
Comment 15 Adolfo Jayme 2014-04-19 19:39:01 UTC
Context menus have been historically hard to find and use. Of course we’d like to have that Citrus floating toolbar containing Cut/Paste/etc. at the cursor’s position. Just then we would be able to remove those super vital commands from the Standard toolbar, and “stop encouraging [vague] poor practices” (?!).

As I agree with Cor, and IMHO removing these basic options from the main toolbars doesn’t make LibreOffice any easier to use, WONTFIXing.
Comment 16 Daniel Hulse 2014-04-19 22:38:23 UTC
Cut and paste buttons are not vital. They are always in the contextual menu. I challenge you do find an instance where they aren't. Why should Libreoffice encourage a workflow for this function that is different from most other software? 

Cutting and Pasting are not the same kind of "important functions" as creating a new document, opening, saving, or even opening the navigator or another important widget because they are necessarily contextual. There is no way of cutting or pasting that doesn't rely on either selecting something with the mouse or having the cursor in a specific location. The poor practice that placing this functionality in the toolbar encourages is not placing the cursor in the correct spot before pasting something into the document, which can be frustrating. 

"I wouldn’t like LibreOffice becoming another dumbed-down app! Honestly!"
Really? Are you saying you want LibreOffice to be complicated and difficult to understand? 

As for Mac users, they can use keyboard shortcuts and the global menu, just like they would in iWork.

"So we can expect proposals too to remove buttons to insert a table, an
autotext, a chart, insert a whatever ?"
No, because there isn't a better, commonly used way to do that like there is with copy and paste. At the same time, though, why shouldn't we be scrutinizing what buttons go in the standard toolbar? If you look in the links Heiko added, you'll find that it mentions in the conclusions that "toolbars should be tidied up, e.g. removing some seldom used function or merging some functions." The standard toolbar is beyond full--just look at what happens when you make the window take up half the page: Many important buttons are hidden, making that section of the toolbar nearly useless. In addition, how do you think it feels for a new user to open up LibreOffice and see a wall of icons? It's intimidating, and prevents people from actually learning what all the buttons do.