Bug 77306 - PDF: Export as PDF messes up the page
Summary: PDF: Export as PDF messes up the page
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.3.1 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-11 07:31 UTC by Charles Bell
Modified: 2014-04-18 21:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
attachment-2592-0.html (2.85 KB, text/html)
2014-04-13 08:51 UTC, Charles Bell
Details
attachment-2592-1.dat (1 bytes, multipart/alternative)
2014-04-13 08:51 UTC, Charles Bell
Details
Latest_Resume.odt (35.59 KB, application/vnd.oasis.opendocument.text)
2014-04-13 08:51 UTC, Charles Bell
Details
Latest_Resume.pdf (69.30 KB, application/pdf)
2014-04-13 08:51 UTC, Charles Bell
Details
attachment-11904-0.html (2.35 KB, text/html)
2014-04-14 07:57 UTC, Charles Bell
Details
attachment-11904-1.dat (1 bytes, multipart/alternative)
2014-04-14 07:57 UTC, Charles Bell
Details
Erroneous_PDF.jpeg (225.70 KB, image/jpeg)
2014-04-14 07:57 UTC, Charles Bell
Details
Erroneous_PDF-Ocular.jpeg (29.02 KB, image/jpeg)
2014-04-14 07:57 UTC, Charles Bell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Bell 2014-04-11 07:31:45 UTC
Problem description: 

Steps to reproduce:
1. ....Write more than one page of text
2. ....Select to "Export as PDF"
3. ....Save as PDF

Current behavior: Half of the first page is unreachable.  It shows the full page in the left panel but you cannot read below the first half of the page.  NOTHING below the middle can be viewed.

Expected behavior: The full page of text should be legible and available to view.

Also in the print section "Print to PDF" is no no longer available.              
Operating System: Ubuntu
Version: 4.2.3.1 rc
Comment 1 tommy27 2014-04-13 08:06:08 UTC
please upload a test .odt file and it's messed PDF version to let us see exactly which kind of issue you experience.

set status to NEEDINFO.
revert it to UNCONFIRMED once requested files are provided.
Comment 2 Charles Bell 2014-04-13 08:51:21 UTC
Created attachment 97295 [details]
attachment-2592-0.html

I have attached the files here.  If you don't receive them,
let me know and we can make other arrangements.
Thank you!

Charles Bell
Comment 3 Charles Bell 2014-04-13 08:51:21 UTC
Created attachment 97296 [details]
attachment-2592-1.dat
Comment 4 Charles Bell 2014-04-13 08:51:21 UTC
Created attachment 97297 [details]
Latest_Resume.odt
Comment 5 Charles Bell 2014-04-13 08:51:21 UTC
Created attachment 97298 [details]
Latest_Resume.pdf
Comment 6 tommy27 2014-04-13 15:39:50 UTC
tested under Win7x64 with LibO 4.2.2.1 and multiple PDF readers (Adobe Acrobat Pro 7.1; PDFXchange Viewer 2.5; FOxit PDF Reader 5.4)

the PDF output you attached looks fine to me and is identical to the ODT input
I can also export again that ODT again to PDF and I still see no issues

which PDF reader are you using? would you please post a screenshot showing what you actually see as a bug in your computer?
Comment 7 Charles Bell 2014-04-14 07:57:32 UTC
Created attachment 97336 [details]
attachment-11904-0.html

On 04/13/2014 11:39 AM, bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 6 <https://bugs.freedesktop.org/show_bug.cgi?id=77306#c6>
> on bug 77306 <https://bugs.freedesktop.org/show_bug.cgi?id=77306> from
> tommy27 <mailto:barta@quipo.it> *
> tested under Win7x64 with LibO 4.2.2.1 and multiple PDF readers (Adobe Acrobat
> Pro 7.1; PDFXchange Viewer 2.5; FOxit PDF Reader 5.4)
>
> the PDF output you attached looks fine to me and is identical to the ODT input
> I can also export again that ODT again to PDF and I still see no issues
>
> which PDF reader are you using? would you please post a screenshot showing what
> you actually see as a bug in your computer?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
The attachments are for the PDF and the PDF viewer (Ocular).
The second picture shows the info about Ocular.
As I stated before this is repeatable with other documents and
only recently showed up.
Thank you!

Charles Bell
Comment 8 Charles Bell 2014-04-14 07:57:32 UTC
Created attachment 97337 [details]
attachment-11904-1.dat
Comment 9 Charles Bell 2014-04-14 07:57:32 UTC
Created attachment 97338 [details]
Erroneous_PDF.jpeg
Comment 10 Charles Bell 2014-04-14 07:57:32 UTC
Created attachment 97339 [details]
Erroneous_PDF-Ocular.jpeg
Comment 11 tommy27 2014-04-14 12:26:30 UTC
I suspsect that's an issue of that Ocular PDF reader since I have no issue at all with your file and other PDF softwares.
Comment 12 Jorendc 2014-04-18 21:35:26 UTC
(In reply to comment #11)
> I suspsect that's an issue of that Ocular PDF reader since I have no issue
> at all with your file and other PDF softwares.

Indeed, I also fail to reproduce, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 619b4c40da9e85febbb08a3f7cf8aa8d10963fc1
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-04-18_00:07:53 by exporting the .odt myself + open your attached 'wrong' pdf. Both pdf's shows correctly.

Marking as RESOLVED NOTOURBUG.

Kind regards,
Joren