Bug 77328 - Cross reference not working with footnotes
Summary: Cross reference not working with footnotes
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: x86 (IA32) Windows (All)
: highest critical
Assignee: Not Assigned
Depends on:
Reported: 2014-04-11 12:58 UTC by gherardo.carullo
Modified: 2015-07-18 17:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

footnotes are zero-numbered (53.06 KB, image/png)
2014-05-01 13:18 UTC, gidici61
footnotes are no more zero-numbered clicking on the first (48.40 KB, image/png)
2014-05-01 13:32 UTC, gidici61

Note You need to log in before you can comment on or make changes to this bug.
Description gherardo.carullo 2014-04-11 12:58:38 UTC
I'm working on a rather large file (>100 pages) with a lot of footnotes (> 100 per chapter, 6 chapters).
ODT format.
Cross references to footnotes are all wrong, both page numbers and footnote number.
If I enter a cross reference (e.g. "see footnote n. 23, at page 40"), it then outputs a reference to some other footnote and page (e.g. "see footnote n. 2, at page 5"). Usually it refers to low numbers, like in the example.

Unfortunately I can not provide the file as an example, but I think the problem can be easily replicated since it shows in all computer I have worked with, since at least v. 4.1 of LO.

In the file there are also Zotero references.

For a research paper like mine this makes LO unusable, so please do something about it asap!
Comment 1 William Friedman 2014-04-25 04:32:47 UTC
Confirming this bug for a document involving 133 footnotes, the final section of which (from fn. 127 onwards) needed to repeat fn. 127 as a cross-reference 4 times, and fns. 128-129 as cross-references once each. When attempted in the original document, the cross-references would appear as references to random footnotes, often about halfway through the document (e.g., a cross-ref. intended for fn. 127 would appear -- and link to -- fn. 66). When I copied that section out of the document and into a new document, set up the cross-references as necessary with only 13 footnotes, and then copied it back to the original document, it appears to have worked. This is clearly not a solution had I needed the cross-references to be to distant sections of the document.
Comment 2 gidici61 2014-05-01 13:18:22 UTC
Created attachment 98293 [details]
footnotes are zero-numbered
Comment 3 gidici61 2014-05-01 13:23:15 UTC
Comment on attachment 98293 [details]
footnotes are zero-numbered

I'm working on a large .odt file with 248 pages, 71870 words, 499467 characters.  If I try to add a corss reference to a footnote, the list shows many of them zero-numbered.
Comment 4 gidici61 2014-05-01 13:32:33 UTC
Created attachment 98295 [details]
footnotes are no more zero-numbered clicking on the first

If I click on the first zero-numbered footnote, numbers change starting from 1 and links do work.
Comment 5 gidici61 2014-05-01 14:19:11 UTC
EDIT: I tried once again but it didn't work.  Sorry.  
Footnotes numbers are still zero.  
Clicking on a cross reference goes to the wrong footnote.
So, LibreOffice is unusable for me.  Shall I remove all cross references to footnotes?
Comment 6 zzz 2014-05-29 18:05:50 UTC
I want to report similar bug for LO debian paket
In a document with 393197 characters, 49543 words, 119 pages 26 chapters and 198 footnotes the cross references to chapter of a footnote always contains ??.
cross references to footnote number and footnote page, that didn't work in seem to be fixed in
Comment 7 Kumāra 2014-07-02 06:04:09 UTC
I've tried this on and notice no issues with a footnote 88 on page 48 (Total 77 pages). 

Can you all please provide the earliest version this bug is seen? The version field says while OP says "at least v. 4.1".

According to Comment 6, "cross references to footnote number and footnote page, that didn't work in seem to be fixed in" Can others confirm?
Comment 8 gidici61 2014-08-24 21:22:59 UTC
Now I'm using LibreOffice
If I open an ".odt" document containing 608068 characters and 298 pages and immediately I try to add a cross-reference, footnotes numbers start always from 0, so the bug still remains.
But if I try again after having done something, footnotes start from 1.
It appears a random behaviour; don't know what unlock the program.
Comment 9 Joel Madero 2014-11-02 15:57:55 UTC
Never CONFIRMED so UNCONFIRMED is the appropriate status.
Comment 10 Buovjaga 2014-11-15 13:44:32 UTC
Please provide a sample document. You can anonymize with this:

Change back to UNCONFIRMED after you have provided the document.
Comment 11 QA Administrators 2015-06-08 14:29:08 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 12 QA Administrators 2015-07-18 17:27:42 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO

Message generated on: 2015-07-18