Bug Hunting Session
Bug 77337 - FORMATTING: No option to set the default date format for fields
Summary: FORMATTING: No option to set the default date format for fields
Status: RESOLVED DUPLICATE of bug 41044
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-11 16:18 UTC by Cocavan
Modified: 2015-02-03 16:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cocavan 2014-04-11 16:18:06 UTC
Problem description:

I see how to change the date format from the default format (mm/dd/yy) to any other date format, e.g., dd MMMM YYYY, but the feature seems to be valid only on an ad hoc basis.  That's not good enough.

I don't like your default date format, e.g., 04/11/14.  I prefer a professional format, e.g., 11 April 2014.  I want to change the default from what you've got in the system to what I want to appear whenever I use the "insert date field" feature.

If I can do that already, the means are not clear---so please enlighten me; if I can't do that already, then you should add that feature to the program.  Thanks.
Operating System: Windows 7
Version: 4.2.2.1 release
Comment 1 m.a.riosv 2014-04-12 12:48:29 UTC
Cocavan, at least for me, doesn't seem too much friendly, how you are requesting for an enhancement.

I think if you really want to catch the attention of a developer, remember no one is obligated to attend your request, perhaps would be better open a new bug, as a request for enhancement (changing the importance from normal to enhancement=, with a bit more kindly words.

As work around, you can record a macro, assigning it to key combination or a button.
Comment 2 Owen Genat (retired) 2014-07-06 00:50:24 UTC
This is an enhancement request to change the default format (when using Insert > Field > Date) from DD/MM/YY to some other (user-specified) format e.g., DD MMMM YYYY, YYYY-MM-DD, NN, D MMM YY, etc. Currently the form (DD/MM/YY vs MM/DD/YY) of the default date is influence by the document language and I imagine this would need to be taken into consideration as well.

Platform / Architecture set to All / All. Severity set to enhancement. Status set to NEW.
Comment 3 Owen Genat (retired) 2014-07-08 02:17:50 UTC
This bug seems like a duplicate of bug 41044. If it is, then the related bug needs to be changed to an enhancement request (as the feature has never existed).
Comment 4 Cor Nouws 2015-02-03 16:50:01 UTC
(In reply to Owen Genat from comment #3)
> This bug seems like a duplicate of bug 41044. If it is, then the related bug
> needs to be changed to an enhancement request (as the feature has never
> existed).

Indeed - thanks!

*** This bug has been marked as a duplicate of bug 41044 ***