Bug 77338 - PIVOTTABLE: LibreOffice on OS X crashes when creating a pivot table
Summary: PIVOTTABLE: LibreOffice on OS X crashes when creating a pivot table
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-11 17:11 UTC by carl
Modified: 2014-04-11 22:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen recording movie file (1.21 MB, video/quicktime)
2014-04-11 17:11 UTC, carl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description carl 2014-04-11 17:11:34 UTC
Created attachment 97231 [details]
screen recording movie file

Problem description: I want to create a pivot table from an existing spreadsheet. Libre Office crashes as soon as I the new sheet is displayed.

Steps to reproduce:
1. menu Data > Pivot Table > Create...
2. In dialog "Select Source" I choose "Current selection" (which nicely selects all my content, i.e. A1:AH277)
3. In the "Pivot table" dialog I fill Row, Column and Data fields each with a one different field from the list and click OK

Current behavior: A new sheet appears with a proper pivot table and in the next moment the application crashes.

Expected behavior: No crash.

              
Operating System: Mac OS X
Version: 4.2.3.3 rc
Comment 1 m.a.riosv 2014-04-11 21:25:52 UTC
Hi carl, thanks for reporting.

Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Comment 2 carl 2014-04-11 22:00:56 UTC
Hi m.a.riosv,

thanks a lot for that hint! I think it wasn't the problem but nonetheless it helped me to track down the problem: it seems to be connected with another software running on my Mac. As soon as I quit all other programs I was able to create pivot tables both in OS X 10.6 and 10.8. 

I usually have QuicKeys (a macro recorder / task automation utility software) running in the background, and that's what seems to have caused the trouble. That teaches me a lesson...

I set the status to resolved / invalid, hope that's ok.

Thanks again,
Carl
Comment 3 m.a.riosv 2014-04-11 22:05:53 UTC
Nice to see your issue solved by yourself, and thanks you for the feedback Carl, it is always helpful.

From your explanation, maybe better as not our bug.