Download it now!
Bug 77403 - FILEOPEN: soffice.bin crashed with SIGSEGV in writerfilter::dmapper::ListDef::GetPropertyValues()
Summary: FILEOPEN: soffice.bin crashed with SIGSEGV in writerfilter::dmapper::ListDef:...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: haveBacktrace
: 77404 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-13 16:56 UTC by Markus J Schmidt
Modified: 2014-09-29 20:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
.docx that leads to a crash of LibreOffice Writer (32.18 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-04-13 16:56 UTC, Markus J Schmidt
Details
console logs + bt with symbols (19.68 KB, text/plain)
2014-04-13 18:40 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus J Schmidt 2014-04-13 16:56:25 UTC
Created attachment 97314 [details]
.docx that leads to a crash of LibreOffice Writer

Downstream bug in launchpad available: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1305273 (private)

Writer crashes consistently attempting to open https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1305273/+attachment/4079977/+files/Der%20Fragenkatalog%20zur%20Analyse%20von%20Projekten-AP.docx .

WORKAROUND: Open with AbiWord.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: libreoffice-core 1:4.2.3~rc3-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Apr 9 21:35:26 2014
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationDate: Installed on 2013-05-30 (314 days ago)
InstallationMedia: Xubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin --writer /tmp/Der\ Fragenkatalog\ zur\ Analyse\ von\ Projekten-AP.docx --splash-pipe=5
SegvAnalysis:
 Segfault happened at: 0x7feb1829febd: mov (%rsi),%rax
 PC (0x7feb1829febd) ok
 source "(%rsi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 ?? () from /usr/lib/libreoffice/program/../program/libwriterfilterlo.so
 ?? () from /usr/lib/libreoffice/program/../program/libwriterfilterlo.so
 ?? () from /usr/lib/libreoffice/program/../program/libwriterfilterlo.so
 writerfilter::dmapper::DomainMapper::lcl_table(unsigned int, boost::shared_ptr<writerfilter::Reference<writerfilter::Table> >) () from /usr/lib/libreoffice/program/../program/libwriterfilterlo.so
 writerfilter::LoggedStream::table(unsigned int, boost::shared_ptr<writerfilter::Reference<writerfilter::Table> >) () from /usr/lib/libreoffice/program/../program/libwriterfilterlo.so
Title: soffice.bin crashed with SIGSEGV in writerfilter::dmapper::DomainMapper::lcl_table()
UpgradeStatus: Upgraded to trusty on 2014-03-23 (17 days ago)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo
Operating System: Ubuntu
Version: 4.2.3.3 rc
Comment 1 Julien Nabet 2014-04-13 18:31:55 UTC
*** Bug 77404 has been marked as a duplicate of this bug. ***
Comment 2 Julien Nabet 2014-04-13 18:40:47 UTC
Created attachment 97317 [details]
console logs + bt with symbols

On pc Debian x86-64 with master sources updated today, I could reproduce the crash.
Comment 3 Julien Nabet 2014-04-13 18:41:59 UTC
Miklos: one for you?
Comment 4 Caolán McNamara 2014-09-27 19:49:35 UTC
caolanm->julien: This seems to not crash for me in master, latest 4.3 and latest 4.2 branches, can you confirm that too ?
Comment 5 Julien Nabet 2014-09-29 20:12:41 UTC
julien->caolanm: Sorry for the delay, I retested it with LO Debian package 4.3.1.2, I don't reproduce this anymore.

I put it as WFM.

Markus: if you can still reproduce this one, don't hesitate to reopen this tracker.