Bug 77419 - Cannot align text to bottom of cell in row of table split over pages
Summary: Cannot align text to bottom of cell in row of table split over pages
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Alignment
  Show dependency treegraph
 
Reported: 2014-04-14 07:01 UTC by Adriano Borgobello
Modified: 2022-01-08 14:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot with LibO 4.2.3 (288.96 KB, image/png)
2014-04-14 07:01 UTC, Adriano Borgobello
Details
Writer file showing problem with bottom alignment in tables spanning pages (20.53 KB, application/vnd.oasis.opendocument.text)
2022-01-08 14:49 UTC, R. Green
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adriano Borgobello 2014-04-14 07:01:30 UTC
Created attachment 97333 [details]
Screenshot with LibO 4.2.3

If I have multipage tables with raws splitted across pages, and in some cells I try to align the text to the bottom of the cell, the text won't jump to second page where the row bottom really is, but will remain at the bottom from the first page. The problem seems to be the same from NeoOffice 3.4.1 (based on OOo 3.x code) to LibreOffice 4.2.3
Comment 1 sophie 2014-04-23 13:29:31 UTC
Confirmed with a new document, as seen in you screenshot. Version 4.2.4.1 Ubuntu 14.04 - Changed plateform to all and set as New - Sophie
Comment 2 Gordo 2015-04-25 19:52:04 UTC
Still reproducible.

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 3 QA Administrators 2016-09-20 09:31:58 UTC Comment hidden (obsolete)
Comment 4 Regina Henschel 2016-12-28 23:05:46 UTC
The problem still exists in Version: 5.4.0.0.alpha0+
Build ID: 690cf2a5ac87d3d05c45a86944e7f6b0adf12cf2
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-15_18:59:20
Locale: de-DE (de_DE); Calc: group
Comment 5 Adriano Borgobello 2016-12-29 10:12:06 UTC Comment hidden (obsolete)
Comment 6 Adriano Borgobello 2016-12-29 10:14:33 UTC
(In reply to Adriano Borgobello from comment #5)
> Still present on LibO 5.2.3, and tested to be there in LibO 3.3.0m19 US.

P.S. Both on macOS 10.11.6
Comment 7 QA Administrators 2017-12-30 03:29:21 UTC Comment hidden (obsolete)
Comment 8 Adriano Borgobello 2017-12-30 14:46:33 UTC
Still present in 5.4.3 (macOS 10.11.6). Tried to reproduce in 6.0 RC1, but program crashes immediately after opening any document... even a new one, but that's another problem.
Comment 9 QA Administrators 2019-10-04 03:05:15 UTC Comment hidden (obsolete)
Comment 10 Commit Notification 2020-01-22 12:54:42 UTC Comment hidden (obsolete)
Comment 11 László Németh 2020-01-22 19:04:25 UTC Comment hidden (obsolete)
Comment 12 Timur 2020-01-30 16:34:48 UTC
Please attach the sample.
Comment 13 R. Green 2022-01-08 14:49:09 UTC
Created attachment 177399 [details]
Writer file showing problem with bottom alignment in tables spanning pages

Version: 7.1.5.2 / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Calc: threaded

This issue has still not been resolved after over 6 years! Open the attached writer file. Place the cursor in the blank cell and press "Align Bottom" (Table toolbar at botom of window).

EXPECTED RESULT: Cursor should move to the bottom of the cell on the next page.

ACTUAL RESULT: Cursor only moves to the bottom of the first page.