Download it now!
Bug 77510 - macro error in all 4.x.y- versions
Summary: macro error in all 4.x.y- versions
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.2.3.2 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-16 06:21 UTC by Andreas Matthus
Modified: 2015-02-22 20:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test-file (68.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-04-16 06:21 UTC, Andreas Matthus
Details
error-picture (119.30 KB, image/png)
2014-04-16 06:22 UTC, Andreas Matthus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Matthus 2014-04-16 06:21:55 UTC
Created attachment 97444 [details]
test-file

In 3.x.y this macro works fine, but in all 4.x.y it breaks with runtime-error.

To confirm use table "Stammdaten" and click on "Neuen Beleg eingeben / Belege bearbeiten". It produce an runtime-error in module MIC line
if oD1.getcontrol("datum").date="" then

Is libreoffice not upward-compatible?

with regards
Andreas Matthus
Comment 1 Andreas Matthus 2014-04-16 06:22:58 UTC
Created attachment 97445 [details]
error-picture
Comment 2 sophie 2014-04-16 12:44:15 UTC
Hi, there has been several changes since 4.1.x versions, please have a look to our release notes here:
https://wiki.documentfoundation.org/ReleaseNotes/4.1#API_Changes
https://wiki.documentfoundation.org/ReleaseNotes/4.2#API_Changes
Could you confirm? Sophie
Comment 3 raal 2014-10-13 07:06:07 UTC
Hello Andreas,
I don't understand German, but I think it's solved in this post:
http://www.libreoffice-forum.de/viewtopic.php?f=12&t=12940
Please, take a look.
Comment 4 LeMoyne Castle 2015-02-12 09:03:27 UTC
Works in 3.5.7.2 (dialog shows up) and 
Fails on 4.5.0.0alpha built from recent master. 

Error is: BASIC runtime error. Incorrect property value.

The incorrect value is for a dialog control called "datum" in object oD1 (first dialog?).  oD1 appears to be all there in watch window, although dialog has not shown.  

Digging a little deeper (Google translating much of forum linked by raal) and 
experimenting a little bit perhaps the API has changed as the forum states.  
Replace '.date' with '.Text' on the line with the error and the dialog comes up without error.  Error message says incorrect value - it may well be incorrect property name.
Comment 5 raal 2015-02-12 09:18:33 UTC
(In reply to LeMoyne Castle from comment #4)
> Works in 3.5.7.2 (dialog shows up) and 
> Fails on 4.5.0.0alpha built from recent master. 
> 
> Error is: BASIC runtime error. Incorrect property value.
> 
> The incorrect value is for a dialog control called "datum" in object oD1
> (first dialog?).  oD1 appears to be all there in watch window, although
> dialog has not shown.  
> 
> Digging a little deeper (Google translating much of forum linked by raal)
> and 
> experimenting a little bit perhaps the API has changed as the forum states.  
> Replace '.date' with '.Text' on the line with the error and the dialog comes
> up without error.  Error message says incorrect value - it may well be
> incorrect property name.

Thanks LeMoyne for testing!
Closing as notabug.
Andreas, you can always set status to UNCONFIRMED if I'm wrong.
Comment 6 Andreas Matthus 2015-02-22 20:25:02 UTC
Thanks LeMoyne for testing! 
Yes change from .date to .text on all places let run the macro ...
but date is not the same and by using other errors appears too ...
I think, we should close the "bug" - too many chances in the API makes a conversion difficult. Whats a pity. So I will use a old version until I find a other macro-set for my exertion.

with regards
Andreas Matthus