Download it now!
Bug 77736 - VIEWING: Smoothed graph line not drawn correctly
Summary: VIEWING: Smoothed graph line not drawn correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-21 18:20 UTC by Milan Bouchet-Valat
Modified: 2017-03-06 14:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ODS file to reproduce the bug (34.67 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-04-21 18:20 UTC, Milan Bouchet-Valat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2014-04-21 18:20:31 UTC
Created attachment 97696 [details]
ODS file to reproduce the bug

In the attached ODS file, the smoothed line is not drawn correcly here with LO 4.2.3.3-6 on Fedora 20: the line is full of weird white shapes. If I disable the Display -> Enable smoothing global LO option, the line is correct. Same if I disable the smoothing when choosing line type in the graph preferences.

Is this specific to my configuration? I have an Intel Ironlake Mobile GPU ("intel" X.org driver).
Comment 1 Buovjaga 2014-11-08 15:10:34 UTC
Unable to repro. Maybe Linux or system specific?

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: c989f5e0e11e295b11ffc921b0d105869e037e47
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-07_22:50:48
Comment 2 Milan Bouchet-Valat 2014-11-08 16:02:50 UTC
It would be interesting to hear whether somebody else on Linux but with a different GPU sees the same bug.
Comment 3 Buovjaga 2014-11-09 15:02:10 UTC
Bingo! On Manjaro KDE the blue line is messed up with white artifacts.

Info: Gallium 0.4 on AMD RV620.

Version: 4.3.2.2.0+
Build ID: 4.3.2.2 Arch Linux build-1

Windows 4.3.3.2 was fine.
Comment 4 Buovjaga 2015-01-08 17:18:37 UTC
Lowered version number after reproducing with:

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Can also repro with

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: f92183833fa569006602ac7e93c906d2094e0d4d
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-14_00:21:45
Comment 5 Buovjaga 2015-01-08 17:19:06 UTC
I lower the severity per: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 6 QA Administrators 2016-01-17 20:02:51 UTC Comment hidden (obsolete)
Comment 7 Milan Bouchet-Valat 2016-01-18 09:41:22 UTC
Still present in 5.0.4.2-3.fc23.
Comment 8 QA Administrators 2017-03-06 13:59:43 UTC Comment hidden (obsolete)
Comment 9 Milan Bouchet-Valat 2017-03-06 14:06:34 UTC
Cannot reproduce with 5.2.6.1 (Fedora 25).