Bug 77780 - Losing format when pasting from Base to Calc
Summary: Losing format when pasting from Base to Calc
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-22 20:46 UTC by Jocelyn Landreville
Modified: 2017-02-16 18:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jocelyn Landreville 2014-04-22 20:46:25 UTC
When I copy a view from Base to Calc, the number format are lost. If they were like ###,## in Base, they are now ###.## in Calc. If I only copy a cell, the format is preserved.
Comment 1 Buovjaga 2014-10-31 19:47:46 UTC
I'd like to try and reproduce this, but I'm not very experienced with Base, so I would like to have a more detailed breakdown of "copying a view from Base". Thanks.
Comment 2 Jocelyn Landreville 2014-11-01 18:34:31 UTC
(In reply to Beluga from comment #1)
> I'd like to try and reproduce this, but I'm not very experienced with Base,
> so I would like to have a more detailed breakdown of "copying a view from
> Base". Thanks.

I'll try to make it clear ;) In fact, I copy the results of the view. First of all, I select all rows I want to copy. Then, on the left part of the view table, I right click and select Copy. Next, I go in Calc and paste in the destination cell.

Hope that it will help you to reproduce the error.
Comment 3 Buovjaga 2014-11-01 21:23:01 UTC
(In reply to Jocelyn Landreville from comment #2)
> (In reply to Beluga from comment #1)
> > I'd like to try and reproduce this, but I'm not very experienced with Base,
> > so I would like to have a more detailed breakdown of "copying a view from
> > Base". Thanks.
> 
> I'll try to make it clear ;) In fact, I copy the results of the view. First
> of all, I select all rows I want to copy. Then, on the left part of the view
> table, I right click and select Copy. Next, I go in Calc and paste in the
> destination cell.
> 
> Hope that it will help you to reproduce the error.

Well, to be honest that didn't help me understand the process, although I now managed to get the same result as you.

First, I thought that I had to use the Create view functionality. In the View design I was quite lost. I could run a query to display the floating point numbers I had created, but I could not copy multiple cells at once.
Then I went back to the Table Data View and there I realized I could highlight all the data by using shift-click on the grey boxes on the left side of the data, where the green triangle appears. Now when I right-clicked a grey box, I could copy all of the data. If right-clicking a cell, it only copied the contents of the cell, which is frankly quite unintuitive when having a multi-selection.

When I pasted the data to calc, the format was indeed changed to ###.## and Format Cells didn't change it to ###,## no matter how hard I tried, even though the whole time it said Format code is 0,00.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 1baad070d8c2a38581cf33d803c5043f1974647f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-01_00:15:06
Comment 4 QA Administrators 2015-12-20 16:16:59 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-01-03 19:49:38 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2017-02-16 18:23:12 UTC
I confirm the problem is gone.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: ac8197327d3ef4f3c94fb0746393863404df086b
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 11th 2016